View Single Post
Old 10-11-05, 12:45 PM   #1
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Important update for users of Linux/x86-64 >= Linux 2.6.11

Please note: if you are using 1.0-8174 or a more recent NVIDIA Linux graphics driver release, you do not need to update your driver.

Linux/x86-64 kernels >= Linux 2.6.11 have a bug in their implementation of the global_flush_tlb() kernel interface that can lead to severe stability problems in combination with the NVIDIA Linux/x86-64 graphics driver and/or other drivers relying on the change_page_attr()/global_flush_tlb() kernel interfaces. This problem is not expected to be fixed before Linux 2.6.14 (final) is released.

The patches below for the 1.0-7676 and 1.0-7174 NVIDIA Linux/x86-64 graphics driver releases work around this problem. It is highly recommended that users of affected Linux kernels and NVIDIA Linux/x86-64 graphics drivers apply these patches.

Update instructions for the 1.0-7174 driver release:

# sh /path/to/NVIDIA-Linux-x86_64-1.0-7174-pkg2.run --extract-only
# cd NVIDIA-Linux-x86_64-1.0-7174-pkg2
# patch -p0 < /path/to/NVIDIA_kernel-1.0-7174-1386866.diff.txt
# ./nvidia-installer -n
Update instructions for the 1.0-7676 driver release:

# sh /path/to/NVIDIA-Linux-x86_64-1.0-7676-pkg2.run --extract-only
# cd NVIDIA-Linux-x86_64-1.0-7676-pkg2
# patch -p0 < /path/to/NVIDIA_kernel-1.0-7676-1386866.diff.txt
# ./nvidia-installer -n
Please also see http://www.nvnews.net/vbulletin/showthread.php?t=56150 for additional 1.0-7676 (http://www.nvnews.net/vbulletin/showthread.php?t=50150 for 1.0-7174) NVIDIA Linux graphics driver updates that improve stability on Linux/x86-64.
Attached Files
File Type: txt NVIDIA_kernel-1.0-7174-1386866.diff.txt (2.4 KB, 1007 views)
File Type: txt NVIDIA_kernel-1.0-7676-1386866.diff.txt (2.4 KB, 1392 views)
zander is offline