View Single Post
Old 02-14-03, 05:23 PM   #6
sbrady
Registered User
 
Join Date: Feb 2003
Posts: 3
Default Re: GLXBadRenderRequest error with remote client

I get the 'connection refused' error with all of the screensavers that I've tried, with the exception of t3d (atlantis, bubble3d, cage, dangerball, gears, gflux, glplanet, gltext, moebius, molecule, morph3d, pipes, rubik, sierpinski3d, stairs, starwars, and superquadrics). This happens regardless of whether or not the machine running the X server has the NVidia drivers installed. On a machine without the drivers, they all seem to run, but I imagine that if there's an X server using :0.0 running on the client-side, a connection to it will be made!

I'm not getting this problem at home, although I do still suffer from the GLXBadRenderRequest error. On the machine that's running the X server, I have Debian 3.0 along with the 4191 driver and XFree86 4.1.0.1. On the machine that's running the client, I have Red Hat 7.0 without the NVidia drivers, and XFree86 4.0.2. Does anybody have remote GLX working with NVidia drivers on the server-side, with/without NVidia drivers on the client-side?

With the NVidia drivers, bubble3d, dangerball, gears, gltext, molecule, morph3d, pipes, rubik, sierpinski3d, starwars, and t3d work when run remotely, using the NVidia drivers locally (I.e. on the X server, rather than the machine that I connect to). All of the others give the GLXBadRenderRequest error. Atlantis and glplanet can be made to run by passing -no-texture or -wireframe. Superquadrics can be made to run by using -wireframe. I get exactly the same results at home. (Stairs, cage, and moebius seem to ignore the -wireframe option!)

Last edited by sbrady; 02-14-03 at 05:35 PM.
sbrady is offline   Reply With Quote