View Single Post
Old 12-13-05, 10:22 PM   #1
Chireru
Registered User
 
Join Date: Dec 2005
Posts: 3
Default How to enable translucency?

I've given it a decent shot, but it doesn't seem to be working for me..

Kubuntu 5.10 Breezy
6600 GT
nVidia Version: 1.0-8174 (IA32)

Made these modifications to my xorg.conf:
Quote:
Section "Device"
Identifier "NVIDIA Corporation NV43 [GeForce 6600/GeForce 6600 Ultra]"
Driver "nvidia"
VideoRAM 131072
Option "AllowGLXWithComposite" "1"
Option "RenderAccel" "true"
BusID "PCI:1:0:0"
EndSection

Section "Extensions"
Option "Composite" "Enable"
Option "RENDER" "Enable"
EndSection
I can see these new options being discovered in the log, and loading with no issues. I've also turned on Translucency & Shadows in kcontrol.

The logs look fine except for these two lines, right after the nvidia driver finishes loading:
Quote:
Symbol __glXgetActiveScreen from module /usr/X11R6/lib/modules/extensions/libdri.a is unresolved!
Symbol __glXgetActiveScreen from module /usr/X11R6/lib/modules/extensions/libdri.a is unresolved!
Also, xdriinfo doesn't work:
Quote:
$ xdriinfo
xdriinfo: symbol lookup error: xdriinfo: undefined symbol: glXGetProcAddress
No other errors or warnings, and the and no translucency. Looks like I've missed something that's causing these errors. My guess is a missing file at compile time.. I can't seem to find anything in the repositories even similar to this.
Any ideas?
Chireru is offline   Reply With Quote