View Single Post
Old 12-15-05, 05:06 PM   #5
Arkantos
Registered User
 
Join Date: Nov 2005
Posts: 1
Default Re: Error inserting nvidia (nvidia.ko)

I had the same error about 20 minutes ago :-) I think it is related to frame buffer splash. I use Gentoo 2005.1 and I wanted to use fbsplash. Then I configured my kernel options like this:

Code:
Linux Kernel Configuration: 2.6

Device Drivers > Graphics support:[*] Support for frame buffer devices
 <*>   VESA VGA graphics support
         VESA driver type (vesafb-tng)  --->
 (HRESxVRES@FREQ) VESA default mode    # pick resolution@freq of your own here !
                                       # 8pp is the only one supported for this time
                                       # Ex: (1024x768@72)
Device Drivers > Graphics support > Console display driver support:[*] Video mode selection support
 <*> Framebuffer Console support
At first I activated the Nvidia Framebuffer Support in the kernel but nvidia driver gave an error about this. So I deactivated this option and recompiled kernel.

And after compiling the kernel I got the same error:

Error inserting nvidia (/lib/modules/2.6.8-24-default/kernel/drivers/video/nvidia.ko): No such device


And also there is nvidia.ko in this directory.

After deactivating framebuffer option completely in the kernel and compiling I finally managed to work nvidia driver again.My graphics card is GeForce 2MX 400.

And in Gentoo the stable display driver doesn't work as expected.

media-video/nvidia-kernel-1.0.6629-r4 and
media-video/nvidia-glx-1.0.6629-r6


So I use the unstable ones:

media-video/nvidia-glx-1.0.8174-r1
media-video/nvidia-kernel-1.0.8174-r1
Arkantos is offline   Reply With Quote