View Single Post
Old 12-15-05, 06:03 PM   #1
Registered User
Join Date: Dec 2005
Posts: 4
Default Installing NVIDIA Drivers


I'm newbie with Linux and i've installed today a ubuntu 5.1

My NVIDIA card is a GeFORCE 5700. X runs well with the nv driver.

I'd like to see if X is faster with the new nvidia driver so i decided to try to install the nvidia drivers.

I installed on my system the kernel sources (2.6.12-10) and headers, but due to package depedencies the synaptic ubuntu thing installed gcc 4

I killed X and launched the installer

ANd well it says that my kernel has no binaries so it needs to rebuild the module but it doesn't like my gcc 4... gcc 3.4 is installed too i think but there might be a VARIABLE problem (CC=?) but i don't know how to fix this...

here are extracts from my /var/log/nvidia-installer.log

-> No precompiled kernel interface was found to match your kernel; would you li
ke the installer to attempt to download a kernel interface for your kernel f
rom the NVIDIA ftp site ( (Answer: No)
-> No precompiled kernel interface was found to match your kernel; this means
that the installer will need to compile a new kernel interface.
-> Performing CC test with CC="cc".
-> gcc-version-check failed:

You appear to be comiling the NVIDIA kernel module with a different compiler
than the one that was used to compile the running kernel. The Linux 2.6 ker
nel module loader rejects kernel modules built with a version of gcc that do
es not exactly match that of the compiler used to build the running kernel.
The compiler used to compile the kernel was gcc 3.4; the current compiler is
gcc 4.0.

and at the end :

> Kernel module compilation complete.
ERROR: Unable to load the kernel module 'nvidia.ko'. This is most likely
because the kernel module was built using the wrong kernel source files.
Please make sure you have installed the kernel source files for your
kernel and that they are properly configured; on Red Hat Linux systems,
for example, be sure you have the 'kernel-source' RPM installed. If you
know the correct kernel source files are installed, you may specify the
kernel source path with the '--kernel-source-path' command line option.
-> Kernel module load error: insmod: error inserting './usr/src/nv/nvidia.ko':
-1 Invalid module format

thanks a lot in advance for your help

nfkb is offline   Reply With Quote