View Single Post
Old 12-28-05, 04:13 AM   #1
baerentzen
Registered User
 
Join Date: Aug 2003
Posts: 5
Default Inno3D 6600 GT bios

Hello,

I am the not quite happy owner of an Inno3D 6600 GT-AGP graphics card. The card initially did not work with the installed graphics card bios numbered 05.43.02.80.00 - at least not under Linux. It seemed to work fine under Windows.

Based on suggestions in this forum, I have downgraded to another bios: 05.43.02.61.00. Now it works under Linux when I disable the check for the power connector cable.

However, the performance appears to be poor. I have an MSI 5900 XT card. Using this card I get 6800 fps in glxgears and 31 FPS with my own program that does a lot of work in both vertex and fragment shaders.

Using the 6600 GT card, the performance drops to 2227 FPS in glxgears and 26 fps in my own program.

Isn't that odd? I have attached the Xorg.0.log. I could not attach the conf file, but extracts are shown after this post. The driver is 7664 but I get similar results with 8178. The agp info is:

jab@linux:/proc/driver/nvidia/agp> cat status
Status: Enabled
Driver: AGPGART
AGP Rate: 8x
Fast Writes: Enabled
SBA: Enabled

Could someone suggest a solution to this problem? For instance, a bios that is known to work under Linux with this card.

All help is appreciated :-)

Happy new year

Andreas
------------------
Section "ServerFlags"
Option "AllowMouseOpenFail"
Option "RandR" "on"
EndSection

Section "Module"
Load "glx"
Load "type1"
Load "extmod"
Load "dbe"
Load "freetype"
Load "v4l"
EndSection

Section "InputDevice"
Driver "kbd"
Identifier "Keyboard[0]"
Option "Protocol" "Standard"
Option "XkbLayout" "dk"
Option "XkbModel" "pc104"
Option "XkbRules" "xfree86"
EndSection

Section "InputDevice"
Driver "mouse"
Identifier "Mouse[1]"
Option "Buttons" "7"
Option "Device" "/dev/input/mouse1"
Option "InputFashion" "Mouse"
Option "Name" "PS/2-Mouse;ExplorerPS/2"
Option "Protocol" "ExplorerPS/2"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "Stylus"
Option "Device" "/dev/input/event3"
Option "InputFashion" "Pen"
Option "Mode" "Absolute"
Option "Name" "GRAPHIRE / INTUOS Stylus (USB)"
Option "Type" "stylus"
Option "USB" "on"
Option "Vendor" "WACOM"
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "Eraser"
Option "AlwaysCore" "0"
Option "Device" "/dev/input/event3"
Option "InputFashion" "Eraser"
Option "Mode" "Absolute"
Option "Name" "GRAPHIRE / INTUOS Eraser (USB)"
Option "Type" "eraser"
Option "USB" "on"
Option "Vendor" "WACOM"
EndSection

Section "Monitor"
DisplaySize 340 270
HorizSync 30-83
Identifier "Monitor[0]"
ModelName "LG ELECTRONICS L1720B"
Option "DPMS"
VendorName "GSM"
VertRefresh 43-75
UseModes "Modes[0]"
EndSection

Section "Modes"
Identifier "Modes[0]"
Modeline "1280x1024" 134.72 1280 1352 1488 1728 1024 1025 1028 1068
Modeline "1024x768" 67.48 1024 1080 1184 1344 768 769 772 797
Modeline "1024x768" 79.52 1024 1080 1192 1360 768 769 772 801
Modeline "800x600" 40.19 800 832 912 1024 600 601 604 623
Modeline "800x600" 47.53 800 840 920 1040 600 601 604 626
Modeline "640x480" 25.10 640 656 720 800 480 481 484 498
Modeline "640x480" 29.84 640 664 728 816 480 481 484 501
EndSection

Section "Screen"
Option "NoPowerConnectorCheck"
DefaultDepth 24
SubSection "Display"
Depth 15
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 32
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
Device "Device[0]"
Identifier "Screen[0]"
Monitor "Monitor[0]"
EndSection

Section "Device"
BoardName "GeForce FX 5900XT"
BusID "1:0:0"
Driver "nvidia"
Identifier "Device[0]"
Screen 0
Option "Rotate" "off"
VendorName "NVidia"
EndSection

Section "ServerLayout"
Identifier "Layout[all]"
InputDevice "Keyboard[0]" "CoreKeyboard"
InputDevice "Mouse[1]" "CorePointer"
InputDevice "Stylus"
InputDevice "Eraser"
Option "Clone" "off"
Option "Xinerama" "off"
Screen "Screen[0]"
EndSection

Section "DRI"
Group "video"
Mode 0660
EndSection

Section "Extensions"
EndSection
Attached Files
File Type: log Xorg.0.log (31.9 KB, 137 views)
__________________
jab "replace with at" imm.dtu.dk
baerentzen is offline   Reply With Quote