View Single Post
Old 01-03-06, 08:02 PM   #15
HellSpawn
Registered User
 
Join Date: Jan 2005
Posts: 21
Exclamation Re: 1.0-8178_problems_with_X

Quote:
Originally Posted by zander
@HellSpawn: chances are you're still seeing problems caused by the linux-restricted-modules package(s), as implied earlier in this thread.
I uninstalled every linux-restricted and nvidia releated

my xorg.0.log reported " ERR: API mismatch: NVIDIA kernel module is version 1.0.7667 but this X module is version 1.0.8178.", that's when I realized I had tu uninstall all the restricted crap...

Quote:
igor@ubuntu:~/nvdownloads$ sudo apt-get --purge remove nvidia-glx linux-restricted-modules-`uname -r`
Password:
Reading package lists... Done
Building dependency tree... Done
Package nvidia-glx is not installed, so not removed
Package linux-restricted-modules-2.6.12-10-amd64-k8 is not installed, so not removed
0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.
igor@ubuntu:~/nvdownloads$
The problem I'm haveing is that something is missing from the booting configuration, because when I install 8178 and run startx it works, and the next reboot it won't. But I don't know what it is. Please if you got any hints let me know.

And when I try to re-install 6629 (latest stable for me) I get "ERROR: Unable to build the NVIDIA kernel module."
__________________
Ubuntu 5.10 Breezy Badger 64bits
PNY Geforce 6200 256MB AGP 8x VGA Dvi Svid HDtv Breakout Pod
AMD ATHLON 64 3000+ (Socket 754)
MOBO Gigabyte GA-K8NS nForce3
RAM 1Gb DDR400
Kernel: Linux ubuntu 2.6.12-10-amd64-k8 #1 Thu Dec 22 11:12:06 UTC 2005 x86_64 GNU/Linux
Nvidia Driver: 8178 64bits
HellSpawn is offline   Reply With Quote