View Single Post
Old 01-07-06, 06:56 PM   #5
bannerboy
Registered User
 
bannerboy's Avatar
 
Join Date: Jul 2004
Posts: 27
Default Re: Xinerama, with acceleration

allow me to be more spacific, here's my xorg.conf file:
Code:
# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
        # paths to defoma fonts
    FontPath 	"/usr/share/X11/fonts/misc"
    FontPath 	"/usr/share/X11/fonts/100dpi:unscaled"
    FontPath 	"/usr/share/X11/fonts/75dpi:unscaled"
    FontPath 	"/usr/share/X11/fonts/Type1"
    FontPath 	"/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
    FontPath 	"/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID"
    FontPath 	"/usr/local/share/fonts"
EndSection

Section "Module"
	Load	"GLcore"
	Load	"i2c"
	Load	"bitmap"
	Load	"ddc"
	Load	"dri"
	Load	"extmod"
	Load	"freetype"
	Load	"glx"
	Load	"int10"
	Load	"type1"
	Load	"vbe"
EndSection

Section	"InputDevice"
    Identifier	"Keyboard1"
    Driver	"kbd"
    Option	"AutoRepeat" "500 30"

    Option	"XkbModel" "microsoftmult"
    Option	"XkbLayout" "us"
EndSection

Section "Input Device"
    Identifier	"Mouse1"
    Driver	"mouse"
    Option	"Protocol" "ExplorerPs/2"
    Option	"Device" "/dev/psaux"
    Option	"ZAxisMapping" "4 5"
    Option	"Resoltuion" "256"
EndSection

Section "Monitor"
    Identifier	"SonyDVI"
    HorizSync	28-75
    VertRefresh	60
EndSection

Section "Monitor"
    Identifier	"SonyVGA"
    HorizSync	28-92
    VertRefresh	48-85
EndSection

Section "Monitor"
    Identifier	"AcerView"
    HorizSync	31.5, 38, 48
    VertRefresh	50-90
EndSection

Section	"Monitor"
    Identifier	"SVideo"
    HorizSync	30-68
    VertRefresh	50-120
EndSection

Section "Device"
    Identifier	"NvidiaDVI"
    BusID	"PCI:1:0:0"
    Driver	"nvidia"
#    VideoRam	32768
    Screen	0
    Option	"NoLogo"		"True"
    Option	"ConnectedMonitor"	"DFP"
EndSection

Section "Device"
    Identifier	"NvidiaVGA"
    BusID	"PCI:1:0:0"
    Driver	"nvidia"
#    VideoRam	32768
    Screen	1
    Option	"NoLogo"		"True"
    Option	"ConnectedMonitor"	"CRT"
#    Option	"ConnectedMonitor"	"TV"
EndSection

Section "Device"
    Identifier	"NvidiaSVideo"
    BusID	"PCI:1:0:0"
    Driver	"nvidia"
    VideoRam	32768
    Screen	1
    Option	"NoLogo"		"True"
    Option	"ConnectedMonitor"	"TV"
    Option	"TVStandard"		"NTSC-M"
    Option	"TVOutFormat"		"SVIDIO"
EndSection

Section "Screen"
    Identifier	"VGA"
    Device	"NvidiaVGA"
    Monitor	"AcerView"
    DefaultDepth 24
    Subsection	"Display"
	Depth	24
#	Modes	"1024x768" "800x600" "640x480"
	Modes   "800x600" "640x480"
	ViewPort 0 0
    Endsubsection
EndSection

Section "Screen"
    Identifier	"DVI"
    Device	"NvidiaDVI"
    Monitor	"SonyDVI"
    DefaultDepth 24
    Subsection "Display"
	Depth 24
	Modes "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
	ViewPort 0 0
    Endsubsection
EndSection

Section "Screen"
    Identifier	"TV"
    Device	"NvidiaSVideo"
    Monitor	"SVideo"
    DefaultDepth 24
    Subsection	"Display"
	Depth	24
	Modes	"720x480"
	ViewPort 0 0
    Endsubsection
EndSection

Section "Server Layout"
    Identifier	"Main"
    Screen	"DVI"
#    Screen	"TV" RightOf "DVI"
    Screen	"VGA" RightOf "DVI"
    InputDevice	"Mouse1"	"CorePointer"
    InputDevice	"Keyboard1"	"CoreKeyboard"
EndSection

Section "ServerFlags"
    Option	"xinerama"	"true"
EndSection
despite what the thing at the top says, my xorg.conf file is mostly hand-written

I start up kdm, login, and start blender. any portion of the program that I put in the second monitor doesn't display. the window displays, but the contents does not.

Last edited by bannerboy; 01-07-06 at 10:07 PM.
bannerboy is offline   Reply With Quote