View Single Post
Old 01-10-06, 01:42 AM   #1
airflow
Registered User
 
airflow's Avatar
 
Join Date: Jan 2006
Posts: 4
Default vesafb-framebuffer and multiheaded graphicadapters

Hi,

I try to get framebuffer (standard vesafb in kernel) to work with my
multiheaded graphicadapter (nvidia card with dual-dvi). Principially it
works. The problem is, that it seems that the kernel-included vesafb
checks the EDID of *both* the dvi-ports. One of those dvi-ports is
connected to my projector, which is only capable of few, low resolution
modes. As soon as I unplug the projector, everything works as intended
(with my other device, a Samsung LCD-display). It makes no difference,
on which of the two dvi-ports the projector sits, vesafb always checks
both of them and refuses to work if the projector is connected (it is not
enough to turn the projector off, it has to be physically disconnected).

Is there any way to disable activation of framebuffer on one of those
dvi-ports? Of course I only need it on the port where my LCD-display is
connected, but there seems to be no option to specify this?

Another option would perhaps be to use vesafb-tng and to disable
EDID-checking, but perhaps there is a more elegant solution. I also
would rather like to solve the problem without patching the kernel. I
need use of framebuffer on only one of the ports, is this theoretically
possible (standard-console or no console output whatsoever on one
port, framebuffer-video on the other)?

Thanks,
airflow

Last edited by airflow; 01-11-06 at 01:40 AM. Reason: bumping...
airflow is offline   Reply With Quote