View Single Post
Old 01-11-06, 06:10 PM   #1
bw_hh
Registered User
 
Join Date: Jan 2006
Location: Hamburg, Germany
Posts: 5
Default Installing Driver for Nvidia 6600 GT on Suse 10, 64 bit

Hi,

I have some strange effects when trying to install the Nvidia driver on my system. After first install of Suse, I installed the driver via Yast online-update - worked without problems, 3D functionality included. I had problems with Suse and ACPI and therefore installed again with boot-option ACPI=off. 3D did not work anymore - neither by installing via YAST (fetchnvidia.sh) nor by manually install of the newest drivers.

When I'm running binary install, the words are mashed together, the screen is mixed up. The installation seems to work though - on first sight. No warnings, and xorg.conf is updated in the section "Device" (from "Driver nv" to "Driver Nvidia"). I installed driver 8178 with Patch (but same result with different drivers).

Sax2 stops with an error when running "sax2 -m 0=nvidia. SaX.log says:

(EE) NVIDIA(0): Failed to initialize the GLX module; please check in your X
(EE) NVIDIA(0): log file that the GLX module has been loaded in your X
(EE) NVIDIA(0): server, and that the module is the NVIDIA GLX module. If
(EE) NVIDIA(0): you continue to encounter problems, Please try
(EE) NVIDIA(0): reinstalling the NVIDIA driver.
NVIDIA: could not open the device file /dev/nvidia0 (Input/output error).
(EE) NVIDIA(0): The NVIDIA kernel module does not appear to be receiving
(EE) NVIDIA(0): interrupts generated by the NVIDIA graphics device.
(EE) Screen(s) found, but none have a usable configuration.

In Xorg.0.log I found:
(II) LoadModule: "glx"
(II) Loading /usr/X11R6/lib64/modules/extensions/libglx.so
(II) Module glx: vendor="NVIDIA Corporation"
compiled for 4.0.2, module version = 1.0.8178
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.1
(II) Loading extension GLX

(II) Loading /usr/X11R6/lib64/modules/drivers/nv_drv.o
(II) Module nv: vendor="X.Org Foundation"
compiled for 6.8.2, module version = 1.0.1
Module class: X.Org Video Driver
ABI class: X.Org Video Driver, version 0.7

What am I doing wrong here - any ideas? Any more information I could provide? Thanks in advance for your help!
bw_hh is offline   Reply With Quote