View Single Post
Old 02-03-06, 05:28 AM   #4
didierspa
Registered User
 
Join Date: Feb 2006
Location: Paris France
Posts: 4
Default Re: Unable to build the NVIDIA kernel module - kernel 2.6.16-rc1

And now, it works with 2.6.16-rc2 too

BTW, I Use two kernels (the latest prepatch for the stable Linux kernel tree and the latest snapshot for the stable Linux kernel tree -- for now 2.6.15.2 and 2.6.16-rc2).

At first I coudn't use nvidia driver on both, because the installer remove the former when it install a new one.

Eventually I founded a quirky way to get the same driver installed for both kernels :
1. Install the driver for the first kernel
2. To install the driver for the second kernel, don't use the installer but issue following command (eg) :
sh NVIDIA-Linux-x86-1.0-8178-pkg1.run --extract-only
then cd NVIDIA-Linux-x86-1.0-8178-pkg1, edit the Makefile to delete all 'rm' commands and run make install.

You should obviously use the same driver for both kernels and I bet there *is* a cleaner way -- which I'd be pleased to know but at least this one did work for me.
__________________
Didier Spaier, Paris
didierspa is offline   Reply With Quote