View Single Post
Old 02-10-06, 07:37 AM   #1
Div2006
Registered User
 
Join Date: Feb 2006
Posts: 4
Default nVida QUADRO4 400NVS FreeBSD 5.4 & For Monitors...

Hi...
I use FreBSD 5.4 and nVidia 8178 drivers for Quadro4 400NVS. I want use 4 Monitors LCD. But this scheme not working. When starting Xorg server, OS rebooting immediately.
Why??? Thank's for yous answer... May be say step-by-step why start X-server for 4 monitors???? Config file 'xorg.conf' below:
----------------
Section "ServerLayout"
Identifier "X.org Configured"
Screen 0 "Screen0" 0 0
Screen 1 "Screen1" RightOf "Screen0"
Screen 2 "Screen2" RightOf "Screen1
Screen 3 "Screen3" RightOf "Screen2"
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
RgbPath "/usr/X11R6/lib/X11/rgb"
ModulePath "/usr/X11R6/lib/modules"
FontPath "/usr/X11R6/lib/X11/fonts/misc/"
FontPath "/usr/X11R6/lib/X11/fonts/TTF/"
FontPath "/usr/X11R6/lib/X11/fonts/Type1/"
FontPath "/usr/X11R6/lib/X11/fonts/CID/"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi/"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "glx"
Load "record"
Load "xtrap"
Load "freetype"
Load "type1"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psm0"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Monitor Model"
EndSection

Section "Monitor"
Identifier "Monitor1"
VendorName "Monitor Vendor"
ModelName "Monitor Model"
EndSection

Section "Monitor"
Identifier "Monitor2"
VendorName "Monitor Vendor"
ModelName "Monitor Model"
EndSection

Section "Monitor"
Identifier "Monitor3"
VendorName "Monitor Vendor"
ModelName "Monitor Model"
EndSection

Section "Device"
Identifier "Card0"
Driver "nvidia"
VendorName "nVidia Corporation"
BoardName "NV17GL [Quadro4 200/400 NVS]"
BusID "PCI:3:0:0"
Screen 0
Option "TwinView"
Option "TwinViewOrientation" "RightOf"
Option "MetaModes" "1280x1024,1280x1024"
EndSection

Section "Device"
Identifier "Card0a"
Driver "nvidia"
VendorName "nVidia Corporation"
BoardName "NV17GL [Quadro4 200/400 NVS]"
BusID "PCI:3:0:0"
Screen 1
Option "TwinView"
Option "TwinViewOrientation" "RightOf"
Option "MetaModes" "1280x1024,1280x1024"
EndSection

Section "Device"
Identifier "Card1"
Driver "nvidia"
VendorName "nVidia Corporation"
BoardName "NV17GL [Quadro4 200/400 NVS]"
BusID "PCI:3:4:0"
Screen 0
Option "TwinView"
Option "TwinViewOrientation" "RightOf"
Option "MetaModes" "1280x1024,1280x1024"
EndSection

Section "Device"
Identifier "Card1a"
Driver "nvidia"
VendorName "nVidia Corporation"
BoardName "NV17GL [Quadro4 200/400 NVS]"
BusID "PCI:3:4:0"
Screen 1
Option "TwinView"
Option "TwinViewOrientation" "RightOf"
Option "MetaModes" "1280x1024,1280x1024"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1280x1024"
EndSubSection
EndSection

Section "Screen"
Identifier "Screen1"
Device "Card0a"
Monitor "Monitor1"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1280x1024"
EndSubSection
EndSection

Section "Screen"
Identifier "Screen2"
Device "Card1"
Monitor "Monitor2"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1280x1024"
EndSubSection
EndSection

Section "Screen"
Identifier "Screen3"
Device "Card1a"
Monitor "Monitor3"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1280x1024"
EndSubSection
EndSection
------------------------
Once more... When use 'nvidia-setting' as a result - "/libexec/ld-elf.so.1: Shared object "libgtk-x11-2.0.so.400" not found, requiered by "nvidia-settings"
Why???
Thank's
-------------
Serg
Div2006 is offline   Reply With Quote