View Single Post
Old 02-17-06, 06:01 PM   #10
walkingshadow
Registered User
 
Join Date: Feb 2006
Posts: 7
Send a message via ICQ to walkingshadow
Default Re: Very poor Performance

Here is the output of sysctl hw.nvidia:
hw.nvidia.agp.card.rates: 8x 4x
hw.nvidia.agp.card.fw: supported
hw.nvidia.agp.card.sba: supported
hw.nvidia.agp.card.registers: 0x1f000e1b:0x1f004302
hw.nvidia.agp.status.status: enabled
hw.nvidia.agp.status.driver: freebsd (agp.ko)
hw.nvidia.agp.status.rate: 8x
hw.nvidia.agp.status.fw: disabled
hw.nvidia.agp.status.sba: enabled
hw.nvidia.version: NVIDIA FreeBSD x86 NVIDIA Kernel Module 1.0-8178 Wed Dec 14 17:04:30 PST 2005
hw.nvidia.registry.EnableVia4x: 0
hw.nvidia.registry.EnableALiAGP: 0
hw.nvidia.registry.NvAGP: 3
hw.nvidia.registry.EnableAGPSBA: 0
hw.nvidia.registry.EnableAGPFW: 0
hw.nvidia.registry.SoftEDIDs: 1
hw.nvidia.registry.Mobile: 4294967295
hw.nvidia.registry.ResmanDebugLevel: 4294967295
hw.nvidia.registry.FlatPanelMode: 0
hw.nvidia.registry.DevicesConnected: 0
hw.nvidia.registry.VideoEnhancement: 0
hw.nvidia.registry.RmLogonRC: 1
hw.nvidia.registry.DetectPrimaryVga: 0
hw.nvidia.cards.0.model: GeForce FX 5200
hw.nvidia.cards.0.irq: 16
hw.nvidia.cards.0.vbios: 04.34.20.23.00
hw.nvidia.cards.0.type: AGP

nvidia agp gets loaded and uses FreeBSD agp. glxgears still performs at around 300 fps. I really don't know anymore what more I should check. In flight gear I get a framerate of 20fps max. when the plane stands still whereas on the same machine under windows 98 (which is aged and slow and not designed for 3D gaming) I get around 50fps.
walkingshadow is offline   Reply With Quote