View Single Post
Old 03-06-03, 05:30 PM   #55
Desertfox
Registered User
 
Join Date: Mar 2003
Posts: 4
Default Lockup on FreeBSD 5.0-RELEASE

The driver compiled fine, and loads fine according to the dmesg.boot file.

However, when running X, the nvidia splash screen loads, and the default X background loads, but any painting to the screen seems to lock up the computer requiring a hard boot.

here's my XFree86Config:

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "ServerFlags"
Option "Xinerama" "true"
EndSection

Section "Module"
Load "xie"
Load "pex5"
#Load "glx"
Load "dri"
Load "dbe"
Load "record"
Load "extmod"
Load "type1"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Buttons" "7"
Option "ZAxisMapping" "4 5"
#Option "Emulate3Buttons"
Option "Device" "/dev/psm0"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbModel" "pc101"
Option "XkbLayout" "us"
EndSection

Section "Monitor"
Identifier "Monitor0"
HorizSync 31.5 - 79.0
VertRefresh 50.0 - 100.0
EndSection

Section "Device"
Identifier "Card0"
Driver "nv"
ChipSet "GeForce4 Ti 4200"
Card "NVidia GeForce4 Ti 4200"
VendorName "NVIDIA"
BoardName "NVidia GeForce4 Ti 4200"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1280x1024" "1152x864" "1024x768" "640x480"
EndSubSection
EndSection

Any ideas?
Desertfox is offline   Reply With Quote