Thread: Mandrake 9.0
View Single Post
Old 03-11-03, 05:37 PM   #3
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

Quote:
Originally posted by SlaYMode
Load "dri"

and copy this at the end of the conf file:

Section "DRI"
Mode 0666
EndSection


Please, DON'T do this!

DRI is NOT used by the nVidia drivers; loading it will at best make nothing change, and at worst cause other problems (like unresolved symbols in the various X drivers).

The reason for the error reported in your X log -- "failed to initialize the NVIDIA kernel module" -- is generally logged by the kernel module. Check the kernel logs (either dmesg, or /var/log/messages) for why. Most of the time, assuming the kernel module is actually loaded (check with lsmod; look for "nvidia"), this error is caused by a BIOS setting. You should have "PnP OS" set to No, and you should have "Assign IRQ to VGA" set to Yes in your BIOS. But check the kernel logs to make sure; they should have a message about those settings if they are what need to be changed.
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote