View Single Post
Old 04-16-06, 10:04 AM   #5
don_dario
Registered User
 
Join Date: Apr 2006
Posts: 5
Default Re: nVidia8756 driver install problem

METHOD 2

If you follow this method you will use the nvidia installer, in this way you can install every version you wish (even the latest release)

Make sure you graphic card is not among the ones which are NOT SUPPORTED by looking at the list you will find in the NOTES SECTION * So that if that card is among the ones listed you have to use driver 7174 (or lower) (you can install it by going to the archive if nvidia drivers in the Nvidia website)

1) Download the installer from this page according to your architecture (32bit or 64bit)
http://www.nvidia.com/object/unix.html

2) Open Terminal or Konsole and type:
Code:

sudo apt-get install build-essential gcc gcc-3.4


3)
Code:

sudo passwd root

(and set the root password which you will need later)

4) Then:
Code:

uname -r


You will get an output similar to the following: "2.6.12-10-386".
You are interested in the last part of the output ("386" in this case) which represents the architecture of your CPU.

5) Replace "386" in the following command with the architecture you got from "uname -r" (e.g. k7, 686, etc.)

Code:

sudo apt-get install linux-image-386 linux-headers-386


6) Restart your computer (so as to boot in your new kernel)

NOTE: if APT complains because it can't find any package to remove in steps 7-8-9 it's not a problem at all and you can go ahead with the next steps. If there were other errors you should report to me.

7) Then open Terminal or Konsole and type:
Code:

sudo apt-get --purge remove nvidia-glx nvidia-settings nvidia-kernel-common


8 ) remove the file manually:
Code:

sudo rm /etc/init.d/nvidia-*


9) Then:
Code:

sudo apt-get --purge remove linux-restricted-modules-`uname -r`


10) Press CTRL-ALT-F1 (so as to get to the command line, not a windowed terminal, but out of the graphical interface GUI)

login with your username and password (if required)

Code:

sudo /etc/init.d/gdm stop (OR "kdm stop" if you use KDE)


Code:

cd “directory where you have the nvidia installer”
su
CC=gcc-3.4
export CC
exit
CC=gcc-3.4
export CC


If you have Ubuntu 64bit type:

Code:

sudo sh NVIDIA-Linux-x86_64-1.0-7667-pkg2.run


Otherwise if you have Ubuntu 32 bit type:
Code:

sudo sh NVIDIA-Linux-x86-1.0-7667-pkg2.run


NOTE: the name of the installer may vary:
e.g. it could be NVIDIA-Linux-x86_64-1.0-7667-pkg1.run.
So just put the name of the installer you've downloaded from Nvidia website

At a certain point the installer will attempt to find a precompiled module for your kernel on the NVIDIA website. It won't find anything therefore it will ask you whether it should try to compile a module for your kernel: answer "Yes" to its question.

If you have Ubuntu 64bit you can't install OpenGL32bit compatibility libraries, so when the installer asks whether to install it just answer no OR you may want to try a workaround which Draugen found but which I haven't tried myself (look at the PROBLEMS SECTION at the end of the guide: point 5).

11) Make a backup of your xorg.conf
Code:

sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf_backup


[In this way if anything goes wrong and you have problems with the xserver (i.e. if it doesn't start) you can type:

sudo cp /etc/X11/xorg.conf_backup /etc/X11/xorg.conf ]

NOTE: If you use the nvidia installer version 8174 or higher you can go straight to point 12.

Code:

sudo nano /etc/X11/xorg.conf


scroll the file down until you find the line with “Modules” and comment out (by putting a "#" before the line) the 2 lines I put in blue and add Load "glx". It should look like the example below:


Code:

Section "Module" Load "bitmap" Load "dbe" Load "ddc" #Load "dri" #Load “GLcore” Load "extmod" Load "freetype" Load "glx" Load "int10" Load "record" Load "type1" Load "vbe"


Then find the section Device and make sure the word I put in red is “nvidia”:

Code:

Section "Device" Identifier "NVIDIA Corporation NV40 [GeForce 6200 TurboCache]" Driver "nvidia" BusID "PCI:1:0:0"



Code:

CTRL+O to save (yes, use the same name and overwrite the file) CTRL+X to exit


12)
Code:

sudo /etc/init.d/gdm start

(or "kdm start" if you use KDE)

Now you have installed the new nvidia driver.

If you want a "control panel" which shows the settings of your card you might want to install "Nvidia-settings" (this part of the guide has been taken from the Unofficial Ubuntu Starter Guide) although they driver works fine also without it (the choice it's up to you).

13) Open Terminal or Konsole and type

Code:

sudo apt-get install nvidia-settings sudo gedit /usr/share/applications/NVIDIA-Settings.desktop (you can use "kate" instead of "gedit" in KDE)


Insert the following lines into the new file:

Code:

[Desktop Entry] Name=NVIDIA Settings Comment=NVIDIA Settings Exec=nvidia-settings Icon= Terminal=false Type=Application Categories=Application;System;



Save the file and exit.

14) Log out and restart the xserver by pressing CTRL+ALT+Backspace

You will be able to see "Nvidia settings" in the menu (the one from which you launch all the applications)

REMEMBER: every time your kernel is upgraded or changed with another one you have to reinstall the drivers.



--------------> If you are a problem with the refresh rate.....

Tape in console as root:
# nvidia-xconfig --mode 1024x768_85*

* your favorite refresh rate with your monitor, put the same before (when it run well).

Last edited by don_dario; 04-16-06 at 10:20 AM.
don_dario is offline   Reply With Quote