View Single Post
Old 04-21-06, 11:13 AM   #9
kefka005995
Registered User
 
Join Date: Apr 2006
Posts: 5
Default Re: PB: Toshiba Satellite 1410 (Geforce4 420Go), TwinView, TV (Composite), Driver 8756

Quote:
Originally Posted by mlampard
the "MetaModes" option in your xorg.conf also appears to be incorrect. Also, I think that only two output devices can be used at one time. Can you try physically disconnecting the CRT and using the following device section?
Section "Device"
Identifier "device1"
VendorName "NVidia"
BoardName "NVIDIA GeForce4 420 Go (Toshiba)"
Driver "nvidia"
Option "DPMS"
Option "Twinview" "True"
Option "MetaModes" "1024x768,1024x768"
Option "ConnectedMonitor" "DFP,TV"
Option "SecondMonitorHorizSync" "31-83"
Option "SecondMonitorVertRefresh" "56-76"
Option "TVStandard" "PAL-B"
Option "TVOutFormat" "COMPOSITE"
Option "TVOverScan" "1.0"
Option "TwinViewOrientation" "Clone"
EndSection

Well well well...
You're probably right, there only can be two output devices.
But doing the changes makes all freeze.
I can't get anything on anything.
I disconnected my CRT so that only my DFP and TV could be used.
The result is very not good.
I did what you suggested and nothing worked. So I changed the metamodes (in order to use the good one for my DFP and a long list of possible one for my TV) but nothing changed. Then I tried nvidia-auto-select.

There is two versions of bug report :

First one with :
Code:
Section "Device"
    Identifier     "device1"
    Driver         "nvidia"
    VendorName     "nVidia Corp."
    BoardName      "NVIDIA GeForce4 420 Go (Toshiba)"
    Option         "DPMS"
    Option         "TwinView" "TRUE"
    Option         "MetaModes" "modeToshibaS1410, NULL; NULL, modeToshibaS1410; 640x480, 640x480; 720x480, 720x480; 720x576, 720x576; 800x600, 800x600; 1024x768, 1024x768; 640x480_60, 640x480_60; 800x600_60, 800x600_60; 1024x768_60, 1024x768_60"
    Option         "ConnectedMonitor" "DFP,TV"
    Option         "SecondMonitorHorizSync" "31-83"
    Option         "SecondMonitorVertRefresh" "56-76"
    Option         "TVStandard" "PAL-B"
    Option         "TVOutFormat" "COMPOSITE"
    Option         "TVOverScan" "1.0"
    Option         "TwinViewOrientation" "Clone"
#    Option         "TwinViewOrientation" "Clone"
#    Option         "SecondMonitorHorizSync" "30.0 - 49.0"
#    Option         "SecondMonitorVertRefresh" "48.0 - 60.0"
#    Option         "MetaModes" "modeToshibaS1410, modeToshibaS1410 ; modeToshibaS1410, NULL ; NULL, modeToshibaS1410"
EndSection
DFPandTV1.zip


Second one with :
Code:
Section "Device"
    Identifier     "device1"
    Driver         "nvidia"
    VendorName     "nVidia Corp."
    BoardName      "NVIDIA GeForce4 420 Go (Toshiba)"
    Option         "DPMS"
    Option         "TwinView" "TRUE"
    Option         "MetaModes" "modeToshibaS1410, nvidia-auto-select"
    Option         "ConnectedMonitor" "DFP,TV"
    Option         "SecondMonitorHorizSync" "31-83"
    Option         "SecondMonitorVertRefresh" "56-76"
    Option         "TVStandard" "PAL-B"
    Option         "TVOutFormat" "COMPOSITE"
    Option         "TVOverScan" "1.0"
    Option         "TwinViewOrientation" "Clone"
#    Option         "TwinViewOrientation" "Clone"
#    Option         "SecondMonitorHorizSync" "30.0 - 49.0"
#    Option         "SecondMonitorVertRefresh" "48.0 - 60.0"
#    Option         "MetaModes" "modeToshibaS1410, modeToshibaS1410 ; modeToshibaS1410, NULL ; NULL, modeToshibaS1410"
EndSection
DFPandTV2.zip


I would be so gratefull to have the solution...

Well, in all the cases, thank you for trying to help me...
kefka005995 is offline   Reply With Quote