View Single Post
Old 04-23-06, 08:01 PM   #1
stephen_wq
Registered User
 
Join Date: Apr 2006
Posts: 7
Default gcc-version-check failed (FC5)

In an attempt to install the drivers, and got the following:
gcc-version-check failed:
Could not compile gcc-version-check.c. Please be sure you have your distrubutions libc development package installed and that 'cc' is a valid c compiler name.
i have done what is in the sticky, but the install doesnt work, so i tried a search. This led me to use
export CC=gcc-3.4
which i then ran it again.
Result:
Could not compile gcc-version-check.c. Please be sure you have your distrubutions libc development package installed and that 'gcc-3.4' is a valid c compiler name.
I tried using gcc, and back to cc, and everything.
I even tried downloading any packages named gcc, or gcc-3.4 or anything of the like off yum, but it still doesnt work.
So what do i do, where do i get this compiler from, because i cant find it in the install packages for things off the disc, and its not in yum.
Ideas?
Distrubution: Fedora Core 5
Graphics chip: Geforce 4 mx440

edit: Dont know if this helps, but
gcc returns:
gcc: no input files
cc returns:
cc: no input files

So that must mean they are there?

edit2: I just installed the headers for glibc or whatever off yum, and tried again. Same result.
So i chose no to continue, and it tells me i dont have libc headers?
Why can there not be a precompiled one for the latest kernel? It would make things so much easier.

Last edited by stephen_wq; 04-23-06 at 08:45 PM.
stephen_wq is offline   Reply With Quote