View Single Post
Old 04-28-06, 04:19 AM   #4
d13f00l
Registered User
 
Join Date: Apr 2005
Posts: 197
Default Re: Squished fonts with TwinView & forced DPI

Your fonts are gross, in all 3 screenshots. Notice how parts of the letters are thicker than others? It's not supposed to be like that.

Recompile freetype, disable "autohint", enable BCI, use font hinting.

I was getting similar garbage recently, squished fonts, and trashy looking fonts. Freetype recently started using the autohinter by default. Unless you're using subpixel hinting font AA, it looks like trash IMHO.

Look for distro-specific documentation on how to enable BCI in freetype. Make sure your GTK libraries are up to date as well.

Edit: Also, under KDE's Control Panel, Appearance & Themes, GTK Styles and Fonts, try having GTk use your KDE fonts. It should apply the same settings. I'm not sure if you need the QT GTK engine for that option in the Control Panel or not, if it doesnt show, try installing the QT engine for GTK.
d13f00l is offline   Reply With Quote