Thread: 1080i
View Single Post
Old 04-28-06, 03:40 PM   #5
Kevin-B
Registered User
 
Join Date: Apr 2006
Posts: 12
Default Re: 1080i

Quote:
Originally Posted by reub2000
I have my 1080i TV hooked up to my mytv box using a hdmi-dvi cable connected to the GeForce 6600. However the video card refuses to work in 1080i. Apparently the TV is sending an EDID signal telling the video card it can't handle 1080i. However disabling EDID mode validation makes it so that no mode is getting validated at all.
I have the same problem with my GeForce 6600 connected to a Sharp AQUOS LCD TV set running the NVidia 1.0.8756 driver. The Sharp AQUOS is capable of both 1080i and 720p. I was able to work around the problem noted by the original poster by setting NoVertRefreshCheck, but I'm running into a problem with the bounding box calculation for a 1080i mode defined in the configuration file. (I'll explain later why I want to do this.) Below, I've reproduced snippets of the log file and my configuration file to show where the problem lies. I've also attached a .zip file with the full /etc/X11/xorg.conf and /var/log/Xorg.0.log.

Here is a somewhat snipped copy of EDID report from /var/log/Xorg.0.log:
Code:
(--) NVIDIA(0): --- EDID for Sharp HDMI (DFP-0) ---
(--) NVIDIA(0): EDID Version                 : 1.3
(--) NVIDIA(0): Manufacturer                 : SHP
(--) NVIDIA(0): Monitor Name                 : Sharp HDMI
(--) NVIDIA(0): Product ID                   : 4032
(--) NVIDIA(0): 32-bit Serial Number         : 16843009
(--) NVIDIA(0): Serial Number String         : 
(--) NVIDIA(0): Manufacture Date             : 2005, week 0
(--) NVIDIA(0): DPMS Capabilities            : Active Off
(--) NVIDIA(0): Prefer first detailed timing : Yes
(--) NVIDIA(0): Supports GTF                 : No
(--) NVIDIA(0): Maximum Image Size           : 820mm x 460mm
(--) NVIDIA(0): Valid HSync Range            : 15kHz - 46kHz
(--) NVIDIA(0): Valid VRefresh Range         : 59Hz - 61Hz
(--) NVIDIA(0): 
(--) NVIDIA(0): Detailed Timings:
(--) NVIDIA(0):   1920 x 1080 @ 60Hz
(--) NVIDIA(0):     Pixel Clock      : 74.25 MHz
(--) NVIDIA(0):     HRes, HSyncStart : 1920, 2008
(--) NVIDIA(0):     HSyncEnd, HTotal : 2052, 2200
(--) NVIDIA(0):     VRes, VSyncStart : 540, 542
(--) NVIDIA(0):     VSyncEnd, VTotal : 547, 562
(--) NVIDIA(0):     H/V Polarity     : +/+
(--) NVIDIA(0):     Extra            : Interlaced
(--) NVIDIA(0):   720  x 480  @ 60Hz
(--) NVIDIA(0):     Pixel Clock      : 27.00 MHz
(--) NVIDIA(0):     HRes, HSyncStart : 720, 736
(--) NVIDIA(0):     HSyncEnd, HTotal : 798, 858
(--) NVIDIA(0):     VRes, VSyncStart : 480, 489
(--) NVIDIA(0):     VSyncEnd, VTotal : 495, 525
(--) NVIDIA(0):     H/V Polarity     : -/-
(--) NVIDIA(0):   1280 x 720  @ 60Hz
(--) NVIDIA(0):     Pixel Clock      : 74.25 MHz
(--) NVIDIA(0):     HRes, HSyncStart : 1280, 1390
(--) NVIDIA(0):     HSyncEnd, HTotal : 1430, 1650
(--) NVIDIA(0):     VRes, VSyncStart : 720, 725
(--) NVIDIA(0):     VSyncEnd, VTotal : 730, 750
(--) NVIDIA(0):     H/V Polarity     : +/+
(--) NVIDIA(0):   1440 x 480  @ 60Hz
(--) NVIDIA(0):     Pixel Clock      : 27.00 MHz
(--) NVIDIA(0):     HRes, HSyncStart : 1440, 1478
(--) NVIDIA(0):     HSyncEnd, HTotal : 1602, 1716
(--) NVIDIA(0):     VRes, VSyncStart : 240, 244
(--) NVIDIA(0):     VSyncEnd, VTotal : 247, 262
(--) NVIDIA(0):     H/V Polarity     : -/-
(--) NVIDIA(0):     Extra            : Interlaced
(--) NVIDIA(0): 
(--) NVIDIA(0): CEA-861B Timings:
(--) NVIDIA(0):   1920 x 1080 @ 60Hz
(--) NVIDIA(0):     Pixel Clock      : 74.18 MHz
(--) NVIDIA(0):     HRes, HSyncStart : 1920, 2008
(--) NVIDIA(0):     HSyncEnd, HTotal : 2052, 2200
(--) NVIDIA(0):     VRes, VSyncStart : 540, 542
(--) NVIDIA(0):     VSyncEnd, VTotal : 547, 562
(--) NVIDIA(0):     H/V Polarity     : +/+
(--) NVIDIA(0):     Extra            : Interlaced
(--) NVIDIA(0):     CEA Format       : 5
The "ModePool" (from the same file) looks reasonable. (The actual reported ModePool is much larger; I've trimmed away the modes that I don't care about.)

Code:
(II) NVIDIA(0): Mode Validation Overrides for Sharp HDMI (DFP-0):
(II) NVIDIA(0):     AllowInterlacedModes
(II) NVIDIA(0):     NoVertRefreshCheck
(II) NVIDIA(0): Frequency information for Sharp HDMI (DFP-0):
(II) NVIDIA(0):   HorizSync   : 15.000-46.000 kHz
(II) NVIDIA(0):   VertRefresh : 59.000-61.000 Hz
(II) NVIDIA(0):     (HorizSync from EDID)
(II) NVIDIA(0):     (VertRefresh from EDID)
(II) NVIDIA(0): 
(II) NVIDIA(0): --- Building ModePool for Sharp HDMI (DFP-0) ---
(II) NVIDIA(0):   Validating Mode "1920x1080":
(II) NVIDIA(0):     1920 x 540 @ 60Hz
(II) NVIDIA(0):     Mode Source: EDID
(II) NVIDIA(0):       Pixel Clock      : 74.25 MHz
(II) NVIDIA(0):       HRes, HSyncStart : 1920, 2008
(II) NVIDIA(0):       HSyncEnd, HTotal : 2052, 2200
(II) NVIDIA(0):       VRes, VSyncStart :  540,  542
(II) NVIDIA(0):       VSyncEnd, VTotal :  547,  562
(II) NVIDIA(0):       H/V Polarity     : +/+
(II) NVIDIA(0):       Extra            : Interlaced
(II) NVIDIA(0):     Mode is valid.
(II) NVIDIA(0): 
(II) NVIDIA(0):   Validating Mode "1280x720":
(II) NVIDIA(0):     1280 x 720 @ 60Hz
(II) NVIDIA(0):     Mode Source: EDID
(II) NVIDIA(0):       Pixel Clock      : 74.25 MHz
(II) NVIDIA(0):       HRes, HSyncStart : 1280, 1390
(II) NVIDIA(0):       HSyncEnd, HTotal : 1430, 1650
(II) NVIDIA(0):       VRes, VSyncStart :  720,  725
(II) NVIDIA(0):       VSyncEnd, VTotal :  730,  750
(II) NVIDIA(0):       H/V Polarity     : +/+
(II) NVIDIA(0):     Mode is valid.
(II) NVIDIA(0): 
(II) NVIDIA(0):   Validating Mode "1920x1080":
(II) NVIDIA(0):     1920 x 540 @ 60Hz
(II) NVIDIA(0):     Mode Source: EDID
(II) NVIDIA(0):       Pixel Clock      : 74.18 MHz
(II) NVIDIA(0):       HRes, HSyncStart : 1920, 2008
(II) NVIDIA(0):       HSyncEnd, HTotal : 2052, 2200
(II) NVIDIA(0):       VRes, VSyncStart :  540,  542
(II) NVIDIA(0):       VSyncEnd, VTotal :  547,  562
(II) NVIDIA(0):       H/V Polarity     : +/+
(II) NVIDIA(0):       Extra            : Interlaced
(II) NVIDIA(0):     Mode is valid.
(II) NVIDIA(0): 
(II) NVIDIA(0):   Validating Mode "1920x1080_kev":
(II) NVIDIA(0):     1920 x 540 @ 60Hz
(II) NVIDIA(0):     Mode Source: X Server
(II) NVIDIA(0):       Pixel Clock      : 74.20 MHz
(II) NVIDIA(0):       HRes, HSyncStart : 1920, 2008
(II) NVIDIA(0):       HSyncEnd, HTotal : 2052, 2200
(II) NVIDIA(0):       VRes, VSyncStart :  540,  542
(II) NVIDIA(0):       VSyncEnd, VTotal :  547,  562
(II) NVIDIA(0):       H/V Polarity     : +/+
(II) NVIDIA(0):       Extra            : Interlaced
(II) NVIDIA(0):     Mode is valid.
(II) NVIDIA(0): 
(II) NVIDIA(0):   Validating Mode "1224x688":
(II) NVIDIA(0):     1224 x 688 @ 60Hz
(II) NVIDIA(0):     Mode Source: X Server
(II) NVIDIA(0):       Pixel Clock      : 74.20 MHz
(II) NVIDIA(0):       HRes, HSyncStart : 1224, 1356
(II) NVIDIA(0):       HSyncEnd, HTotal : 1396, 1648
(II) NVIDIA(0):       VRes, VSyncStart :  688,  709
(II) NVIDIA(0):       VSyncEnd, VTotal :  714,  750
(II) NVIDIA(0):       H/V Polarity     : -/-
(II) NVIDIA(0):     Mode is valid.
Of particular interest (to me anyway) are the modes 1920x1080_kev and 1224x688. 1920x1080_kev is 1080i mode which is nearly identical to the ones from the EDID, but for some reasons the size of the Bounding Box is computed incorrectly. I'll have more to say about this later. My intent was to start out with a working 1080i modeline that I define myself and then tweak it to remove the overscan. An example of this is the 1224x688 mode that I created. This started out as a 720p mode. I adjusted some of the parameters to fix the overscan problem on my TV. My hope is that by using a tweaked 1080i mode, I might end up with a mode that's closer to the native resolution of my TV (1366x768). (I'm guessing that when I'm finally able to do this, I'll end up with something along the lines of 1834x1032. Not exactly what I was hoping for, but I'd like to try it anyway...)

Now, back to my findings...

As I said earlier, the inital ModePool report looks good. But later on, there's a more abbreviated report which doesn't look so good:

Code:
(II) NVIDIA(0): --- Modes in ModePool for Sharp HDMI (DFP-0) ---
(II) NVIDIA(0): "nvidia-auto-select"   : 1920 x 1080 @ 120.1 Hz Interlaced  (from: EDID)
(II) NVIDIA(0): "1920x1080"            : 1920 x 1080 @ 120.1 Hz Interlaced  (from: EDID)
(II) NVIDIA(0): "1920x1080_120i"       : 1920 x 1080 @ 120.1 Hz Interlaced  (from: EDID)
(II) NVIDIA(0): "1920x1080_120i_0"     : 1920 x 1080 @ 120.0 Hz Interlaced  (from: EDID)
<snip>
(II) NVIDIA(0): "1280x720"             : 1280 x  720 @  60.0 Hz  (from: EDID)
(II) NVIDIA(0): "1280x720_60"          : 1280 x  720 @  60.0 Hz  (from: EDID)
(II) NVIDIA(0): "1280x720_60_0"        : 1280 x  720 @  59.9 Hz  (from: EDID)
(II) NVIDIA(0): "1280x720_60_1"        : 1280 x  720 @  60.0 Hz  (from: X Server)
(II) NVIDIA(0): "1224x688"             : 1224 x  688 @  60.0 Hz  (from: X Server)
(II) NVIDIA(0): "1224x688_60"          : 1224 x  688 @  60.0 Hz  (from: X Server)
<snip snip>
(There are more modes than this listed, but I'm striving for brevity. )

For the 1920x1080 modes, note the refresh rate: 120 (or so) Hz. Not good. This is why these modes get tossed out if you don't have enable NoVertRefreshCheck set for the ModeValidation option.

Now we come to the problem of the bounding box for the mode (1920x1080_kev) that I created:

Code:
(II) NVIDIA(0): Assigned Display Device: DFP-0
(II) NVIDIA(0): Requested modes:
(II) NVIDIA(0):     "1920x1080"
(II) NVIDIA(0):     "1920x1080_kev"
(II) NVIDIA(0):     "1224x688"
(II) NVIDIA(0): Validated modes:
(II) NVIDIA(0): MetaMode "1920x1080":
(II) NVIDIA(0):     Bounding Box: [0, 0, 1920, 1080]
(II) NVIDIA(0):     Sharp HDMI (DFP-0): "1920x1080"
(II) NVIDIA(0):         Size          : 1920 x 1080
(II) NVIDIA(0):         Offset        : +0 +0
(II) NVIDIA(0):         Panning Domain: @ 1920 x 1080
(II) NVIDIA(0):         Position      : [0, 0, 1920, 1080]
(II) NVIDIA(0): MetaMode "1920x1080_kev":
(II) NVIDIA(0):     Bounding Box: [0, 0, 1920, 540]
(II) NVIDIA(0):     Sharp HDMI (DFP-0): "1920x1080_kev"
(II) NVIDIA(0):         Size          : 1920 x 540
(II) NVIDIA(0):         Offset        : +0 +0
(II) NVIDIA(0):         Panning Domain: @ 1920 x 540
(II) NVIDIA(0):         Position      : [0, 0, 1920, 540]
(II) NVIDIA(0): MetaMode "1224x688":
(II) NVIDIA(0):     Bounding Box: [0, 0, 1224, 688]
(II) NVIDIA(0):     Sharp HDMI (DFP-0): "1224x688"
(II) NVIDIA(0):         Size          : 1224 x 688
(II) NVIDIA(0):         Offset        : +0 +0
(II) NVIDIA(0):         Panning Domain: @ 1224 x 688
(II) NVIDIA(0):         Position      : [0, 0, 1224, 688]
(II) NVIDIA(0): Virtual screen size determined to be 1920 x 1080
(II) NVIDIA(0): Computing DPI from Sharp HDMI (DFP-0)'s EDID
(II) NVIDIA(0):   width  : 1920 pixels  820  mm (DPI: 59)
(II) NVIDIA(0):   height : 1080 pixels  460  mm (DPI: 59)
Note that the bounding box for mode 1920x1080 was computed correctly, but that (IMO, anyway) the mode for 1920x1080_kev was not. For 1920x1080, the height (number of rows) is 1080 (which is correct). But for 1920x1080_kev, the height is calculated as 540, which is half of what it should be. I'm guessing that the bounding box calculation is unaware of the fact that this is an interlaced mode.

As you might expect, when I switch to 1920x1080_kev, everything looks twice as tall as it should be.

Additional Info:

Here's the relevant portions from /etc/X11/xorg.conf:

Code:
Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Sharp"
    ModelName      "DFP-0"
    HorizSync       15.0 - 46.0
    VertRefresh     59.0 - 61.0
    ModeLine       "1920x1080_kev" 74.2 1920 2008 2052 2200 540 542 547 562 +hsync +vsync interlace
    ModeLine       "1832x1032" 74.2 1832 2008 2052 2200 516 542 547 562 +hsync +vsync interlace
    ModeLine       "1224x688" 74.2 1224 1356 1396 1648 688 709 714 750 -hsync -vsync
    ModeLine       "1192x672" 74.2 1192 1336 1376 1648 672 677 682 750 -hsync -vsync
    Option         "dpms"
    Option         "ExactModeTimingsDVI" "true"
EndSection

Section "Device"
    Identifier     "Videocard0"
    Driver         "nvidia"
    VendorName     "Videocard vendor"
    BoardName      "NVIDIA GeForce 6600"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Videocard0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "ConnectedMonitor" "DFP"
    Option         "FlatPanelProperties" "native"
    Option         "ModeValidation" "AllowInterlacedModes, NoVertRefreshCheck"
    SubSection     "Display"
        Viewport    0 0
        Depth       16
        Modes      "800x600" "640x480"
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       24
        Modes      "1920x1080" "1920x1080_kev" "1224x688"
    EndSubSection
EndSection
Hopefully, this report will help the original poster work around the problem encountered. Hopefully, too it will help NVidia tech support pass along the relevant information to someone capable of fixing the bounding box problem.
Attached Files
File Type: zip nvidia-log-and-conf.zip (16.8 KB, 266 views)
Kevin-B is offline   Reply With Quote