View Single Post
Old 05-14-06, 11:15 PM   #33
D_CrOsS
Registered User
 
Join Date: May 2006
Posts: 1
Thumbs up Re: FC5 fail to load "nvsound.ko"

guys, i've got it working 100%
i will describe all i've done
i've downloaded the NFORCE installer and wang's patch
patched it like wang said
removed from /etc/modprobe.conf :
alias snd-card-0 snd-intel8x0
options snd-intel8x0 index=0
remove snd-intel8x0 { /usr/sbin/alsactl store 0 >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove snd-intel8x0

and added:
alias snd-card-0 nvsound
alias sound-slot-0 nvsound
install nvsound /sbin/modprobe --ignore-install nvsound; sleep 1; /usr/bin/nvmix-reg -f /etc/nvmixrc -L >/dev/null 2>&1 || :
remove nvsound {/usr/bin/nvmix-reg -f /etc/nvmixrc -S >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove nvsound

after this i've edited /etc/rc.local, adding:
/usr/bin/nvmix-reg -f /etc/nvmixrc -L >/dev/null 2>&1

and edited /etc/rc.d/init.d/halt , adding :
if grep -q "\(nvsound\)" /proc/modules && [ -x /usr/bin/nvmix-reg ]; then
/usr/bin/nvmix-reg -f /etc/nvmixrc -S >/dev/null 2>&1
fi

and removing:
grep -q "\(alsa\)" /proc/devices
if [ $? = 0 -a -x /usr/sbin/alsactl ]; then
runcmd $"Saving mixer settings" alsactl store
fi

to stop loading ALSA drivers, i've added this lines to /etc/modprobe.d/blacklist:
# ALSA drivers
blacklist snd_intel8x0
blacklist snd_ac97_codec
blacklist snd_ac97_bus

and it's done

i am not a linux expert, and my english is very poor, i've just posted it here because i've seen a lot of people having trouble with this driver

i think that somebody should stick this solution, because i've spent a lot of time to solve this problem and everybody is spending too, even givin' up
D_CrOsS is offline   Reply With Quote