View Single Post
Old 06-27-06, 09:49 PM   #3
esrevni
Registered User
 
Join Date: Apr 2005
Posts: 11
Default Re: nforce 2 and SuSe 10.1

Ok... hours later and still no luck at all. here's what I've come up with from all my reading. Any suggestions would be GREATLY appreciated... it's been a real quiet last few days *chuckles*

In /etc/modprobe.conf:
Code:
###################
### Sound Stuff ###
###################

# ALSA portion
alias snd-card-0 snd-intel8x0
options snd-intel8x0 ac97_clock=47470
# OSS/Free portion
alias sound-slot-0 snd-card-0
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
In ~/.asoundrc:
Code:
pcm.nforce-hw {
type hw
card 0
}

pcm.!default {
type plug
slave.pcm "nforce"
}

#0,0 is analog out (i.e. headphone socket on the shuttle), and 0,1 is
#spdif out.

pcm.nforce {
type dmix
ipc_key 1234
slave {
pcm "hw:0,1"
period_time 0
period_size 1024
buffer_size 4096
rate 44100
}
}

ctl.nforce-hw {
type hw
card 0
}
here's my aplay outputs:

Code:
linux-j4rh:/home/esrevni # aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: nForce2 [NVidia nForce2], device 0: Intel ICH [NVidia nForce2]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: nForce2 [NVidia nForce2], device 2: Intel ICH - IEC958 [NVidia nForce2 -                               IEC958]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
linux-j4rh:/home/esrevni # aplay
ALSA lib pcm_dmix.c:863:(snd_pcm_dmix_open) unable to open slave
aplay: main:547: audio open error: Device or resource busy
figured this may help too... a snippet from lsmod

Code:
dm_mod                 52584  0
nvidia               4548180  12
i2c_nforce2             6272  0
forcedeth              20612  0
shpchp                 39488  0
pci_hotplug            24372  1 shpchp
snd_intel8x0           30236  5
snd_ac97_codec         82848  1 snd_intel8x0
snd_ac97_bus            2176  1 snd_ac97_codec
snd_pcm                80136  4 snd_pcm_oss,snd_intel8x0,snd_ac97_codec
snd_timer              20868  3 snd_seq,snd_pcm
snd_page_alloc          9608  2 snd_intel8x0,snd_pcm
nvidia_agp              7324  1
agpgart                28976  2 nvidia,nvidia_agp
i2c_core               19728  2 nvidia,i2c_nforce2
ns558                   4612  0
gameport               13960  2 ns558
snd_mpu401              8096  0
snd_mpu401_uart         6912  1 snd_mpu401
snd_rawmidi            23552  2 snd_seq_midi,snd_mpu401_uart
snd_seq_device          7948  4 snd_seq_dummy,snd_seq_midi,snd_seq,snd_rawmidi
snd                    51076  17 snd_seq_dummy,snd_pcm_oss,snd_mixer_oss,snd_seq_midi,snd_seq,snd_intel8x0,snd_ac97_codec,snd_pcm,snd_timer,snd_mpu401,snd_mpu401_uart,snd_rawmidi,snd_seq_device
soundcore               8672  3 snd
NOTE: This is a digital connection, not analog. Have it running from soundcard to my dolby digital reciever (I guess that's called SPDIF?)

Last edited by esrevni; 06-27-06 at 11:41 PM.
esrevni is offline   Reply With Quote