View Single Post
Old 06-29-06, 10:19 PM   #8
esrevni
Registered User
 
Join Date: Apr 2005
Posts: 11
Default Re: nforce 2 and SuSe 10.1 *FIXED!*

Hopefully this will help anyone else that has severe issues getting SPDIF working.

NOTE: This is still not a complete fix... many sound applications still are not working as they require OSS. The OSS emulation DOES NOT and will not work due to the SPDIF being device 2 (oss emulation only handles devices 0 and 1) unless you're one of the lucky folk who happen to have your device set to 0 or 1. If any has information on how to set up OSS with SPDIF, kindly message me

First, make sure you have the newest ALSA available and run the following as root:

# alsaconf

Follow the simple instructions, when it asks if you want modprobe.conf to be set up, select yes.

Now, go back into a shell:

# cat /proc/asound/oss/sndstat

Make sure you have something along the following there:

Code:
Installed drivers:
Type 10: ALSA emulation

Card config:
NVidia nForce2 with ALC650E at 0xe4081000, irq 193
MPU-401 UART at 0x330, irq 10
If you don't, make double sure you have aoss and alsa installed.

next:

# cat /proc/asound/cards

this will list your card(s). make a note of which card you want to be configured as your main sound card. (usually will be 0). then:

# cat /proc/asound/pcm

Look for the device here that has either IEC958 or spdif, you'll want to pay attention to the second set of numbers. That identifies the device number.

In my example, device 2 is my digital out:
Code:
 linux-j4rh:/usr/include # cat /proc/asound/pcm
00-02: Intel ICH - IEC958 : NVidia nForce2 - IEC958 : playback 1 <<<------ this one!
00-01: Intel ICH - MIC ADC : NVidia nForce2 - MIC ADC : capture 1
00-00: Intel ICH : NVidia nForce2 : playback 1 : capture 1
Alright, now that we've got that all figured out, do the following to create a profile for ALSA to read:

# pico /etc/.asoundrc

and put the following:

Code:
pcm.nforce-hw {
type hw
card 0      #### Insert your card number from cat /proc/asound/cards
device 2   #### Insert your device number from cat /proc/asound/pcm
}

pcm.!default {
type plug
slave.pcm "nforce"
}

#0,0 is analog out (i.e. headphone socket on the shuttle), and 0,1 is
#spdif out.

pcm.nforce {
type dmix
ipc_key 1234
slave {
pcm "hw:0,2"            #### Insert card number, device number
period_time 0
period_size 1024
buffer_size 32768
rate 48000
}
}

ctl.nforce-hw {
type hw
card 0        #### Insert your card number from cat /proc/asound/cards
device 2    #### Insert your device number from cat /proc/asound/pcm
}
Nearly done!!

Now you'll need to configure all your sound programs (xmms, xine, etc) to run ALSA. You'll see a setting for PCM (sometimes called audio device). You'll want to set it as follows:

hw:0,2

where the first number is your card number, second is device number.

NOTE: This is for my setup using an A7N8X Deluxe. Your milage may vary but this should theoretically work for most other cards.

Hope this helps someone!!
esrevni is offline   Reply With Quote