View Single Post
Old 07-04-06, 04:57 PM   #5
MiKuS
Registered User
 
Join Date: Jul 2006
Posts: 3
Default Re: nForce4 Onboard sound card

i know about sudo and gksudo and yes, i ran the file as root by:

typing sudo into terminal then dragging the file (puts the path/to/file in there for me) which installed fine. i'm currently running the 2.6 kernel which is where my problem is, i have no sbin directory in / only a sbin in usr, and even still in my usr/ directory there is nothing to do with modprobe, at all. after some more investigation ubuntu uses a system where the modprobe is a directory full of files. the files are only like..one mod it's kinda hard to explain, but there is no one file (like modprobe.conf)
the directory where the files reside is - etc/modprobe.d/

in there theres a file called alsa base, here is it's contents

Code:
# autoloader aliases
install sound-slot-0 modprobe snd-card-0
install sound-slot-1 modprobe snd-card-1
install sound-slot-2 modprobe snd-card-2
install sound-slot-3 modprobe snd-card-3
install sound-slot-4 modprobe snd-card-4
install sound-slot-5 modprobe snd-card-5
install sound-slot-6 modprobe snd-card-6
install sound-slot-7 modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd modprobe --ignore-install snd $CMDLINE_OPTS && { modprobe -Qb snd-ioctl32 ; : ; }
install snd-pcm modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { modprobe -Qb snd-pcm-oss ; : ; }
install snd-mixer modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { modprobe -Qb snd-mixer-oss ; : ; }
install snd-seq modprobe --ignore-install snd-seq $CMDLINE_OPTS && { modprobe -Qba snd-seq-midi snd-seq-oss ; : ; }

# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { modprobe -Qb snd-emu10k1-synth ; }
install snd-via82xx modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { modprobe -Qb snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 modprobe --ignore-install saa7134 $CMDLINE_OPTS && { modprobe -Qb saa7134-alsa ; : ; }
# Prevent abnormal drivers from grabbing index 0
options snd-bt87x index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
i tried to make a nvidia module in there but that didn't work at all and as for nvmixer i got that working by installing the kde librarys, which was only really a fluke, as i was installing amarok and when i was looking for a fix for the missing library i saw the only users that were being effected were those of KDE so i decided to try it and bam it works but whenever i try to change the volume on some of the sliders it gives me an error.

here is my nvidia file from the modprobe.d directory:

Quote:
alias sound-slot-0 nvsound
alias snd-intel8x0 off
alias i810_audio off
install nvsound /sbin/modprobe --ignore-install nvsound ; sleep 1; /usr/bin/nvmix-reg -f /etc/nvmixrc -L >/dev/null 2>&1 || :
remove nvsound { /usr/bin/nvmix-reg -f /etc/nvmixrc -S >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove nvsound
MiKuS is offline   Reply With Quote