View Single Post
Old 07-07-06, 01:02 AM   #1
quickkk
Registered User
 
Join Date: Jul 2006
Posts: 2
Default vsync, compiz, tearing, oh my!

Hi everyone,

I've just installed suse 10.1 and was very eager to try out the compiz 3D desktop. I download and installed the newest nvidia linux drivers, and finally got the 3D desktop working. It's really nice, except for one thing that is really bothering me...

For some reason, whenever I drag a window around horizontally, I notice that there seems to be some "tearing" like I would see in some 3d game running in windows if I didn't enable vsync. It's not a big thing, it's just that I'm going crazy trying to find a solution to the problem. I don't even know if there is a solution! Is this normal behaviour? Am I asking too much?

I spent hours searching this forum and the internet in general, and have tried these following things:

*** disclaimer: I'm really new to linux, and don't understand most things! ***

1) I tried using nvidia-settings. It wasn't working, and eventually I discovered that this doesn't work in conjunction with the 3D desktop.

2) I tried using nvidia-xconfig. I really don't understand how this works. From the Nvidia site http://tinyurl.com/o5t4b there seems to be a whole bunch of options, like "TripleBuffer", but I can't see how to enable them using the nvidia-xconfig utility. All that happens when I type "nvidia-xconfig" is this

Code:
Using X configuration file: "/etc/X11/xorg.conf".
Backed up file '/etc/X11/xorg.conf' as '/etc/X11/xorg.conf.backup'
New X configuration file written to '/etc/X11/xorg.conf'
when I type nvidia-xconfig --help, I don't even see most of the options that are stated in the X Config Options appendix file (at the link above)!

3) After searching this board, I've seen a lot of reference to the magical "__GL_SYNC_TO_VBLANC=1" option. I've tried exporting this like so "export __GL_SYNC_TO_VBLANC=1" and I don't see any changes. There is still tearing when I drag any windows around. I tried putting the export command at the end of my .bashrc file, and rebooted the computer, but I still don't see any changes. Furturmore, I'm not even sure if this setting will only apply to things like games, or if it will affect how the desktop is drawn. I think that it should, since the desktop is 3D (using compiz).

Anyway, I really tired of trying to figure this out. Any help would be greatly appreciated! Thanks,

Sincerely,

Alexis

System specs:

suse 10.1, using the gnome desktop
geforce 6800 128Mb
1GB ram
athlon X2 3800

Last edited by quickkk; 07-07-06 at 01:20 AM.
quickkk is offline   Reply With Quote