View Single Post
Old 07-07-06, 04:24 AM   #22
Hannibal
#356906
 
Hannibal's Avatar
 
Join Date: Feb 2004
Location: Lodz, Poland
Posts: 24
Default Re: 8762 doesn't build under 2.6.17-git

This can be Slackware specific error. I also have it.

Prevoiusly I think that was something wrong with source dir (I apply patches to get newer kernel), but I download vanilla kernel, add my config and run "make bzImage modules", and error still exists.

I try run installer with/whithout latest patch, and with/without --krenel-source-path option under 2.6.18-rc1 kernel and with --kernel-version under 2.6.17 kernel.

I attach my installer log but this is nothnig new.

Edit:
I found something that in strace:
Code:
29395 write(2, "conftest29388.c: In function `ma"..., 36) = 36
29395 write(2, "\n", 1)                 = 1
29395 write(2, "conftest29388.c:4: error: `UTS_R"..., 79) = 79
29395 write(2, "\n", 1)                 = 1
29395 write(2, "conftest29388.c:4: error: (Each "..., 75) = 75
29395 write(2, "\n", 1)                 = 1
29395 write(2, "conftest29388.c:4: error: for ea"..., 59) = 59
I think that, problem may by caused by moving "#define UTS_RELEASE" from version.h to utsrelease.h. I try change conftest.sh and test this.

Edit:
I have right. I include patch that fix this problem
Attached Files
File Type: log nvidia-installer.log (2.6 KB, 154 views)
File Type: txt nvidia-utsrelease.diff.txt (521 Bytes, 239 views)
__________________
Hannibal@Slackware-current

Last edited by Hannibal; 07-07-06 at 06:10 AM.
Hannibal is offline   Reply With Quote