View Single Post
Old 07-11-06, 06:27 AM   #1
chtitux
Registered User
 
Join Date: Jul 2006
Posts: 1
Exclamation Compile fails with linux 2.6.18 (-rc1)

When I try to compile nvidia module with linux 2.6.18-rc1 , I get :
Quote:
FATAL: modpost: GPL-incompatible module nvidia.ko uses GPL-only symbol 'lockdep_init_map'
Little context :
Quote:
make module[...]
Building modules, stage 2.
make -rR -f /usr/src/linux-2.6.16.2/scripts/Makefile.modpost
scripts/mod/modpost -i /usr/src/linux-2.6.16.2/Module.symvers -I /var/tmp/portage/nvidia-kernel-1.0.8762-r1/work/NVIDIA-Linux-x86-1.0-pkg1/usr/src/nv/Modules.symvers -o /var/tmp/portage/nvidia-kernel-1.0.8762-r1/work/NVIDIA-Linux-x86-1.0-8762-pkg1/usr/src/nv/Modules.symvelinux /var/tmp/portage/nvidia-kernel-1.0.8762-r1/work/NVIDIA-Linux-x86-1.0-8762-pkg1/usr/src/nv/nvidia.o
FATAL: modpost: GPL-incompatible module nvidia.ko uses GPL-only symbol 'lockdep_init_map'
make[4]: *** [__modpost] Erreur 1
make[3]: *** [modules] Erreur 2
make[2]: *** [modules] Erreur 2
NVIDIA: left KBUILD.
nvidia.ko failed to build!
make[1]: *** [mdl] Erreur 1
make: *** [module] Erreur 2
Is there any patch to solve that ?
Thanks
chtitux is offline   Reply With Quote