View Single Post
Old 07-15-06, 06:47 PM   #1
phlakvest
Registered User
 
Join Date: Jul 2006
Posts: 3
Default Problems with twinview and games spanning two monitors

Ok heres my Problem.

My card is a geforce 6600GT, and I am running slackware 10,2. I have the newest nvidia driver and I currently have twin view working correctly. I am having the same problem that many other people are having with games spaning both monitors.

I have tried setting a meta mode to 1600x1200,1600x1200; 1600x1200,null and instead of dropping down to one monitor in games it choses to load that mode every time I start X. I have also tried "ctrl"+"alt"+"+" (on the numpad and keypad) and it doesnt change modes.

Heres a copy of my xorg.conf
Code:
Section "ServerLayout"
    Identifier     "Default Layout"
    Screen         "Screen0"
    InputDevice    "Mouse0" "CorePointer"
    InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
    RgbPath         "/usr/X11R6/lib/X11/rgb"
    FontPath        "/usr/X11R6/lib/X11/fonts/misc/"
    FontPath        "/usr/X11R6/lib/X11/fonts/TTF/"
    FontPath        "/usr/X11R6/lib/X11/fonts/Type1/"
    FontPath        "/usr/X11R6/lib/X11/fonts/CID/"
    FontPath        "/usr/X11R6/lib/X11/fonts/75dpi/"
    FontPath        "/usr/X11R6/lib/X11/fonts/100dpi/"
    FontPath        "/usr/X11R6/lib/X11/fonts/local/"
    FontPath        "/usr/X11R6/lib/X11/fonts/Speedo/"
    FontPath        "/usr/X11R6/lib/X11/fonts/cyrillic/"
EndSection

Section "Module"
    Load           "dbe"  	# Double buffer extension
    SubSection     "extmod"
        Option         "omit xfree86-dga"   # don't initialise the DGA extension
    EndSubSection
    Load           "type1"
    Load           "freetype"
    Load           "glx"
EndSection

Section "InputDevice"
    Identifier     "Keyboard0"
    Driver         "kbd"
    Option         "AutoRepeat" "500 30"
    Option         "XkbRules" "xorg"
    Option         "XkbModel" "pc101"
    Option         "XkbLayout" "us"
EndSection

Section "InputDevice"
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "Auto"
    Option         "Device" "/dev/mouse"
    Option         "ZAxisMapping" "4 5"
    Option         "Resolution"  "1200"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    HorizSync       31.5 - 82.0
    VertRefresh     50.0 - 90.0
EndSection

Section "Device"
    Identifier     "Videocard0"
    Driver         "nvidia"
    BusID          "PCI:3:0:0"
    Option 	"NvAGP" "3"
    Option 	"ConnectedMonitor" "CRT-0,CRT-1"
    Option      "IgnoreDisplayDevices"  "TV"
    Option      "TwinView" "true"
    Option      "HorizSync" "50-100"
    Option      "VertRefresh" "60-120"
    Option      "MetaModes" "1600x1200,1600x1200"
CRT-0:1600x1200,CRT-1: null"
    Option      "TwinViewOrientation" "RightOf"


EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Videocard0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
        Modes      "1600x1200"
        ViewPort 0 0
    EndSubSection
EndSection
Thanks in advance for your Help.
phlakvest is offline   Reply With Quote