View Single Post
Old 07-19-06, 01:18 PM   #1
bestokes
Registered User
 
Join Date: Jul 2006
Posts: 5
Default Nvidia fails after reboot

I'm using Ubuntu Dapper. I followed the install instructions listed in the sticky and on the drivers page. I installed the drivers and ran nvidia-xconfig. For some reason, nvidia-xconfig is writing a new xorg.conf file, but puts it in my home directory instead of /etc/X11/. I copied it to /etc/X11 and started the X server. When X comes up, I get an NVIDIA logo page and things seem to be working. I ran glxgears to check OpenGL and this works fine. Oddly, the laptop decides to use the external monitor instead of the main one. When I restart the computer, the x server will not start. I get the following text. I'm not even sure where to start debugging this problem or how to search for topics covering it.

--------------------------------------------------------------------------------------------
xauth: creating new authority file /home/stokes/.serverauth.5349

X Window System Version 7.0.0
Release Date: 21 December 2005
X Protocol Version 11, Revision 0, Release 7.0
Build Operating System:Linux 2.6.15.7 i686
Current Operating System: Linux pulsar2 2.6.15-26-386 #1 PREEMPT Mon Jul 17 19:52:53 UTC 2006 i686
Build Date: 16 March 2006
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Wed Jul 19 12:53:50 2006

(==) Using config file: "/etc/X11/xorg.conf"
Couldn't open RGB_DB '/usr/X11R6/lib/X11/rgb'
Error: API mismatch: the NVIDIA kernel module has the version 1.0-7174, but
this X module has the version 1.0-8762. Please make sure that the kernel
module and all NVIDIA driver components have the same version.
(EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module! Please ensure
(EE) NVIDIA(0): that there is a supported NVIDIA GPU in this system, and
(EE) NVIDIA(0): that the NVIDIA device files have been created properly.
(EE) NVIDIA(0): Please consult the NVIDIA README for details.
(EE) NVIDIA(0): *** Aborting ***
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found
XIO: fatal IO error 104 (Connection reset by peer) on X server ":0.0"
after 0 requests (0 known processed) with 0 events remaining.

--------------------------------------------------------------------------------------------------
bestokes is offline   Reply With Quote