View Single Post
Old 07-27-06, 10:20 PM   #8
whitesuit
Registered User
 
Join Date: Jul 2006
Posts: 9
Default Re: yet again screen frozen mouse moves bug

Quote:
whitesuit, I have a few questions:
0) Does this problem persist with a more recent kernel (2.6.17.x)?
I dont wanna try kernels that are not in my distribution's repositories (ubuntu 6.06), if I do that then I lose support for everything else I have on my system.

Quote:
1) Have you tried reducin the AGP rate in the BIOS?
It doesnt seem to be possible. It stays "grayed out" at 8x. That's why I recompiled the kernel module using 4x as you can see from the logs. No go.

Quote:
2) Does setting RenderAccel to false in xorg.conf have any impact?
Nope. Still crashes.

Quote:
3) If you boot with the noapic and/or acpi=off kernel parameters, does that have any impact?
Tried it. No go.

Quote:
4) If you're feeling adventerous there's a beta BIOS available for your motherboard, that might be worth testing.
I dont wanna risk that much.

I even tried booting with agp=off and using nvagp, but no go also.

Just on a side note: The nv (open source driver has never crashed on me, though i get poor speed compared to the propietary driver using this).

Something I've noticed, might be nothing but..

In my nvidia-installer.log (attached in the first zip) i have:

Code:
include/asm/bitops.h:326: warning: comparison between signed and unsigned
   In file included from include/linux/list.h:7,
                    from include/linux/wait.h:23,
                    from include/asm/semaphore.h:41,
                    from include/linux/sched.h:20,
                    from include/linux/module.h:10,
                    from /home/cassio/NVIDIA-Linux-x86-1.0-8762-pkg1/usr/src/nv
   /nv-linux.h:51,
in my Xorg.0.log the last entries are (this is the log i got after rebooting into a recovery terminal after crash and before starting X again):

Code:
(II) Configured Mouse: ps2EnableDataReporting: succeeded
(WW) NVIDIA(0): WAIT (2, 6, 0x8000, 0xf09210a4, 0x0000d398, 0)
(WW) NVIDIA(0): WAIT (1, 6, 0x8000, 0xf09210a4, 0x0000d398, 0)
(WW) NVIDIA(0): WAIT (2, 6, 0x8000, 0xf09210a4, 0x0000d3a8, 0)
Could this be related to the problem?
whitesuit is offline   Reply With Quote