View Single Post
Old 07-30-06, 09:14 AM   #1
tabanus
Registered User
 
Join Date: Oct 2005
Posts: 37
Default VideoRam not Setting Properly

Similar to, but the opposite of this thread http://www.nvnews.net/vbulletin/showthread.php?t=55335

After migrating to xorg 7.0 (from 6.8), I noticed opengl performance degrade significantly. I started doing some digging about, and discovered that the VideoRam is not being set properly.

I'm using an ASRock K8NF4G-SATA2 board with an integrated GeForce 6100 GPU. I don't know if this is actually affecting performance, or if the problem pre-dates xorg migration.

You will see from the attached files that

Xorg.0.log: VideoRAM: 262144 kBytes
xorg.conf: VideoRam 131072

I have set the BIOS to apply 128MB of shared memory for Video. Changing the value of VideoRam in xorg.conf has no effect. If I comment out the VideoRam value in xorg.conf, xorg still "detects" 262144 kBytes of memory.

I tried setting the BIOS to "Auto" for VideoRam. This results in an allocation of 64MB, yet xorg still reports 262144 kBytes (ie 256MB).

How would I sort this, and is it likely to be the cause of the slow opengl performance? Other than that, I haven't noticed any problems.

I'm using nvidia driver version 1.0.8762
Attached Files
File Type: log Xorg.0.log (19.0 KB, 125 views)
File Type: txt dmesg.txt (14.5 KB, 127 views)
File Type: txt xorg.conf.txt (4.6 KB, 155 views)
tabanus is offline   Reply With Quote