View Single Post
Old 08-02-06, 05:59 PM   #1
dereks
Registered User
 
Join Date: Aug 2006
Posts: 4
Default TwinView not working: FX 5200 on Ubuntu 6.06 LTS

TwinView does not work for me. I have tried every option combination I could find. Every time the result is the same:

(EE) NVIDIA(0): The requested configuration of display devices is not
(EE) NVIDIA(0): supported in the hardware.



I have tried not using TwinView, and instead use two X "Screens", as described here: https://help.ubuntu.com/community/NvidiaTVOut . I get the same result as above.

I have read on a forum post that a newer driver broke TV-Out TwinView for some people that it used to work for, and so I tried the older "legacy" driver:

root@geode:/etc/X11# dpkg -l | grep nvidia-glx-legacy
ii nvidia-glx-legacy 1.0.7174+2.6.15.11-3 NVIDIA binary XFree86 4.x/X.Org 'legacy' dri
root@geode:/etc/X11#


This gives the same result.

If I supply the config option

Option "UseDisplayDevice" "TV-0"

then my TV (and only my TV) works fine, at 1024x768. If I do Option "UseDisplayDevice" "CRT-1" then my LCD monitor (and only my LCD monitor) works fine. If I try Option "UseDisplayDevice" "CRT-1,TV-0" then I get the same old error "The requested configuration of display devices is not supported in the hardware.".

The fact that the log file shows

(--) NVIDIA(0): Connected display device(s) on GeForce FX 5200 at PCI:1:0:0:
(--) NVIDIA(0): Dell 1800FP (CRT-1)
(--) NVIDIA(0): NVIDIA TV Encoder (TV-0)


makes me think that both the TV and the LCD monitor are being detected okay.

The fact that the log file shows

(II) NVIDIA(0): Requested modes:
(II) NVIDIA(0): "1024x768,1024x768"
(II) NVIDIA(0): Validated modes:
(II) NVIDIA(0): MetaMode "1024x768,1024x768":


makes me think that the MetaMode line is okay, and that my simple setting of 1024x768,1024x768 should extend the desktop from the LCD to the TV.


I am stuck. What else to try? I have built myself an awesome MythTV box, I want to run MythTV on the T.V. and have a nice Gnome Desktop on my LCD for websurfing and email.

The nvidia-bug-report.log is attached, which includes my /var/log/Xorg.0.log and my /etc/X11/xorg.conf files.

Any help is greatly appreciated.

Thanks,
Derek
Attached Files
File Type: txt nvidia-bug-report.log.txt (77.5 KB, 138 views)
dereks is offline   Reply With Quote