View Single Post
Old 08-06-06, 02:45 PM   #3
StevenChamberla
Registered User
 
Join Date: Jul 2006
Posts: 14
Default Re: Crashing when SMP enabled

Quote:
Originally Posted by jdtate101
I had the same sort of thing in both suse and ubuntu...turns out some motherboards have problems with SMP (specifically the irqbalancer). If you have smp enabled with irqbalance running, try turning that off, it worked for me, and now I have a 100% stable system. This was supposed to be fixed in 2.6.17.
Thanks for the advice, I still had the problem in 2.6.17 but I will try anyway by booting the kernel with the 'noirqbalancer' option.

Quote:
Originally Posted by jdtate101
> Also try turning off the composite setting if you have it enabled in the xorg.conf file, that
> also was a major point of instability for me.
I do not have the 'composite' extension in my xorg.conf file, but it seems to be somehow built-into Debian's distribution of xorg:
Code:
(II) Initializing built-in extension COMPOSITE
I've not been able to disable it, even adding the following had no effect:
Code:
Section "Extensions"
    Option      "Composite"     "Disable"
EndSection
I think I may have to recompile xorg myself to disable the extension.

I also realised that I have not yet tried disabling TwinView so when I am ready to restart for another test, I will do that at the same time. If I can get either the 'nv' or 'nvidia' driver to work with TwinView disabled I can be more sure that the problem lies with the 'nvidia' driver and not the kernel or hardware.
StevenChamberla is offline   Reply With Quote