View Single Post
Old 08-09-06, 06:14 AM   #1
kazdan
Registered User
 
Join Date: Aug 2006
Posts: 3
Default X fails after update to CentOS 4.3 on Dell Inspiron 8100 [GeForce2 Go]

After updating from Mandriva 10.2 to CentOS 4.3, X failed.
Suggestions are appreciated. -- Jerry

DETAILS
HARDWARE: Dell Inspiron 8100 laptop with 1600x1200 display, VGA
controller: nVidia Corporation NV11 [GeForce2 Go] (rev b2)

BEFORE UPDATE:
I was running Mandriva 10.2 using their kernel linux2.6.11-6 and
nVidia's driver via NVIDIA-Linux-x86-1.0-7667-pkg1.run. It ran
well. [I still have the old xorg.conf from that].

AFTER UPDATE:
Running CentOS 4.3 (=RedHat EL 4.3), their kernel linux
2.6.9-34.0.2.EL. Before installing the nVidia driver X was running
(but at the unpleasant 800x600). Nonetheless, it ran. Then I
installed the nVidia driver using NVIDIA-Linux-x86-1.0-8762-pkg1.run
(this used my kernel-devel-2.6.9-34.0.2.EL). I also used the automatic
modifications to my xorg.conf. When I attempted to restart X (using
startx from runlevel 3), it failed. Here is the startx &>startx.log file:
-------------------------------------------
X Window System Version 6.8.2
Release Date: 9 February 2005
X Protocol Version 11, Revision 0, Release 6.8.2
Build Operating System: Linux 2.6.9-34.EL i686 [ELF]
Current Operating System: Linux localhost.localdomain 2.6.9-34.0.2.EL #1 Fri Jul 7 19:24:57 CDT 2006 i686
Build Date: 04 May 2006
Build Host: x8664-build.centos.org

Before reporting problems, check http://wiki.X.Org
to make sure that you have the latest version.
Module Loader present
OS Kernel: Linux version 2.6.9-34.0.2.EL (buildcentos@v20z-i386) (gcc version 3.4.5 20051201 (Red Hat 3.4.5-2)) #1 Fri Jul 7 19:24:57 CDT 2006
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Tue Aug 8 17:34:50 2006
(==) Using config file: "/etc/X11/xorg.conf"

(EE) NVIDIA(0): Failure reading maximum pixel clock value for display device
(EE) NVIDIA(0): CRT-0.
(EE) NVIDIA(0): Failure reading maximum pixel clock value for display device
(EE) NVIDIA(0): TV-0.
(EE) NVIDIA(0): Failure to determine the TV encoder.
(EE) NVIDIA(0): The requested configuration of display devices is not
(EE) NVIDIA(0): supported in the hardware.

Fatal server error:
AddScreen/ScreenInit failed for driver 0

Please consult the The X.Org Foundation support
at http://wiki.X.Org
for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.

*** If unresolved symbols were reported above, they might not
*** be the reason for the server aborting.

FatalError re-entered, aborting
Caught signal 11. Server aborting

XIO: fatal IO error 104 (Connection reset by peer) on X server ":0.0"

after 0 requests (0 known processed) with 0 events remaining.

-------------------------------------------

My /var/log/Xorg.0.log is included in the attached zip file containing
both the nvidia-bug-report.log and nvidia-installer.log files.

Note that the current (CentOS installation default) xorg.conf has the
inadequate Monitor lines
HorizSync 31.5 - 37.9
VertRefresh 50.0 - 70.0
rather than those from my old xorg.conf file (which worked well with
Mandriva):
HorizSync 31.5-90.0
VertRefresh 59.0-85.0
I did also text the new nVidia use these old values, but the error
persists.

This is all I can think of that might be helpful.
After I get X running at 800x600 (which is unacceptable), I plan to use
my old xorg.conf as a guide to go to 1600x1200.

-- Jerry
Attached Files
File Type: zip nvidia-logs.zip (25.6 KB, 153 views)
kazdan is offline   Reply With Quote