View Single Post
Old 08-14-06, 07:17 PM   #26
JaXXoN
Registered User
 
Join Date: Jul 2005
Location: Munich
Posts: 910
Default Re: Crashing when SMP enabled

You are getting truely strange numbers! The measurement is in
microseconds, btw. Max should stay below 100 for a nanosleep call:

Code:
cyclictest -c 1 -n -p 80 -t 1 -i 1000
options:
c = clock select: 0=CLOCK_MONOTONIC, 1=CLOCK_REALTIME
n = use clock_nanosleep
p = task priority
r = use relative timer instead of absolute timer
i = base intervall in microseconds
t = number of threads.

You may try different options and check if it makes any difference.
This might help isolating the problem.

Did you also applied "idle=poll" as kernel boot option?

regards

Bernhard
JaXXoN is offline   Reply With Quote