View Single Post
Old 08-17-06, 01:48 PM   #14
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Poor Xinerama Performance

The attached bug report indicates that you're using 1.0-8178, not 1.0-8762 (which doesn't require any patches). I'd like to see a bug report against 1.0-8762.

Also, note the following warnings in your X log, which would certainly explain high CPU usage:
(WW) NVIDIA(2): The GPU driving screen 2 is incompatible with the rest of the
(WW) NVIDIA(2): GPUs composing the desktop. OpenGL rendering will be
(WW) NVIDIA(2): disabled on screen 2.
(WW) NVIDIA(3): The GPU driving screen 3 is incompatible with the rest of the
(WW) NVIDIA(3): GPUs composing the desktop. OpenGL rendering will be
(WW) NVIDIA(3): disabled on screen 3.
(WW) NVIDIA(4): The GPU driving screen 4 is incompatible with the rest of the
(WW) NVIDIA(4): GPUs composing the desktop. OpenGL rendering will be
(WW) NVIDIA(4): disabled on screen 4.
(WW) NVIDIA(5): The GPU driving screen 5 is incompatible with the rest of the
(WW) NVIDIA(5): GPUs composing the desktop. OpenGL rendering will be
(WW) NVIDIA(5): disabled on screen 5.

I was under the impression that the test app that you were providing was going to provide a quantifiable measurement of performance, and it seems that your determination is based on comparing CPU usage, which will likely be specific to your hardware setup. Do you have a measurable way of benchmarking this performance?

Also, is the performance problem evident if you're using just two displays with Xinerama?

Thanks,
Lonni
netllama is offline   Reply With Quote