View Single Post
Old 08-28-06, 07:21 AM   #1
xopen
Registered User
 
Join Date: Aug 2006
Posts: 7
Default Black screen in NVIDIA MCP51 + GeForce 6150

First ot all, many thanks for the support provided by this great forum :)

I've been using NVIDIA linux drivers for several years in different laptops successfully, but after 4 days of intense trials I haven't been able to view anything but a black screen using the NVIDIA graphic driver on my new Compaq Presario V6024EA laptop, which comes with a GeForce 6150 and NVIDIA MCP51 chipset.

When looking at the xorg log file it seems that everything works OK but I only get an iluminated black screen on my laptop, which remains the same when I switch back to the console (if I pass "vga=normal video=vesafb:off" to the kernel, I can use the console again, but not the graphic display).

Searching in this forum I haven't find any solution that works for me, and neither testing with the different driver options documented in the README file. I have an updated BIOS and memory tests work OK. The windoze driver seems to work well, but in linux I only can use the graphic environment using the vesa driver.

I use kubuntu 6.06 (Dapper) with a 2.6.15-26-686 SMP kernel on a AMD Turion 64x2 processor (I know I am only using it in 32 bit mode, but I have the same problem with the 64 bit kernel). I have also uninstalled the linux-restricted-modules and nvidia-glx packages and run the NVIDIA-Linux-x86-1.0-8774-pkg1.run directly with the same results. Finally I have also tried compiling the latest stable linux kernel (2.6.17.11) but the same black screen problems remains.

I attach the nvidia-bug-report for the two kernels and the kernel configuration files.

Has anyone ever had and/or solved this kind of problem??, any ideas??, I'm really desesperated and thinking on trying to take back my laptop to the store ...
Attached Files
File Type: zip ubuntu-2.6.15-26-686_nvidia-8774.zip (44.7 KB, 454 views)
File Type: zip linux-2.6.17.11_nvidia-8774.zip (40.1 KB, 371 views)
xopen is offline   Reply With Quote