Thread: Twinview
View Single Post
Old 09-02-06, 05:33 AM   #8
kapa
Registered User
 
Join Date: May 2004
Posts: 4
Default Re: Twinview

Hi all,

I tried nvidia-xconfig --twinview, with little luck:

after making configuration, I restarted my X, and ... no success. I read Xorg.0.log file from /var/log directory, and it gave one hint: Only one display found.

This was because "ConnectedMonitor" were set to "DFP". Earlier I already met this problem. I tried to change the value to "DFP, CRT" (one of the LCDs is connected via analog D-sub), and that caused "white screen" (i.e. both displays became totally white, and I fear those could be broken if trying again)...

But, because I do not want to give up, I continued

Finally, after few unsuccessful tries, I found the configuration for me. It is:

For some reason my graphic card needs to be used in "CRT, DFP" mode. If I put the definition otherway, it leads to problem. But if I do not define Connected monitors at all, the order of identified displays is "analog, digital". So, after discovering this, I needed to change the order of the desktop from "DFP, CRT" to "CRT, DFP".

Here is cut from Xorg.0.log file after changing the configuration:

(**) NVIDIA(0): Option "UseEdidFreqs" "True"
(**) NVIDIA(0): Option "TwinView" "True"
(**) NVIDIA(0): Option "TwinViewOrientation" "LeftOf"
(**) NVIDIA(0): Option "MetaModes" "1280x1024@1280x1050,1680x1050"
(**) NVIDIA(0): Option "Rotate" "off"
(**) NVIDIA(0): Option "Coolbits" "1"
(**) NVIDIA(0): Enabling RENDER acceleration
(**) NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID has been
(**) NVIDIA(0): enabled on all display devices.
(**) NVIDIA(0): TwinView enabled
(**) NVIDIA(0): Disabling static screen rotation.
(II) NVIDIA(0): NVIDIA GPU GeForce4 Ti 4800 SE at PCI:2:0:0
(--) NVIDIA(0): VideoRAM: 131072 kBytes
(--) NVIDIA(0): VideoBIOS: 04.28.20.21.00
(II) NVIDIA(0): Detected AGP rate: 8X
(--) NVIDIA(0): Interlaced video modes are supported on this GPU
(--) NVIDIA(0): Connected display device(s) on GeForce4 Ti 4800 SE at
(--) NVIDIA(0): PCI:2:0:0:
(--) NVIDIA(0): ViewSonic VP171b (CRT-1)
(--) NVIDIA(0): ViewSonic VX2025wm (DFP-0)
(--) NVIDIA(0): ViewSonic VP171b (CRT-1): 350.0 MHz maximum pixel clock
(--) NVIDIA(0): ViewSonic VX2025wm (DFP-0): 165.0 MHz maximum pixel clock
(--) NVIDIA(0): ViewSonic VX2025wm (DFP-0): External Single Link TMDS
(II) NVIDIA(0): Assigned Display Devices: CRT-1, DFP-0
(II) NVIDIA(0): Validated modes:
(II) NVIDIA(0): "1280x1024@1280x1050,1680x1050"
(II) NVIDIA(0): Virtual screen size determined to be 2960 x 1050


And this I got with this configuration:

Section "Screen"
Identifier "Screen[0]"
Device "Device[0]"
Monitor "Monitor[0]"
DefaultDepth 24
Option "Rotate" "off"
# Option "ConnectedMonitor" "DFP"
# DefaultDepth 24
Option "CoolBits" "1"
Option "TwinView" "True"
Option "TwinViewOrientation" "LeftOf"
Option "UseEdidFreqs" "True"
Option "MetaModes" "1280x1024@1280x1050,1680x1050"
SubSection "Display"
Depth 24
Modes "1680x1050" "1600x1024" "1600x1000" "1400x1050" "1280x1
024" "1440x900" "1280x960" "1366x768" "1280x800" "1152x864" "1280x768" "10
24x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
EndSection


The advice to use nvidias own xconfig tool helped me in clarifying the cause of problems, so thank you "very many" for advices
Because, now twinview rocks

This is a bit hard to explain (with my english) but hopefully you understand
kapa is offline   Reply With Quote