View Single Post
Old 09-14-06, 05:26 AM   #1
nickfixit
Registered User
 
Join Date: Sep 2006
Posts: 5
Default Toshiba 6100 NVidia GForce4 420 Go Black Screen

After much pain and web searching here is how I resolved the nvidia 3d patch:

First patch your system upto date using YAST check your kernel (uname -r)

Download the driver from nvidia.

Upack it it using

sh NVIDIA-Linux-x86-1.0-8774-pkg1.run -x


Goto the folder

/usr/src/nv/


and edit the file

os-registry.c

modify the lines:

NVreg_SoftEDID = 0;
NVreg_Mobile = 2;


go down to init 3

init 3

from the folder run:

nvidia-installer -q

Follow the instructioins then:

sax2 -r -m 0=nvidia

(must run -r otherwise you will end up with an 800x600 fussy screen)

This should give you the screen with black bar down the right hand side.

Modify the

/etc/X11/xorg.conf

under the screen section add:

Section "Screen"
Option "ExactModeTimingsDVI" "TRUE"
Option "ModeValidation" "DFP-0: NoEdidDFPMaxSizeCheck, NoVesaModes"


All things being equal that should do it.

Good luck I hope this helps.
nickfixit is offline   Reply With Quote