View Single Post
Old 09-23-06, 04:55 AM   #1
dclemen
Registered User
 
Join Date: Apr 2004
Posts: 49
Default can not play 5.1, only 2 front

Hi I just buy a logitech s500 and I can not play 5.1 on linux (windows works fine)

I have debian testing
dpkg -l |grep alsa
ii alsa-base 1.0.11-5 ALSA driver configuration files
ii alsa-oss 1.0.11-1 ALSA wrapper for OSS applications
ii alsa-tools 1.0.11-1 Console based ALSA utilities for specific ha
ii alsa-tools-gui 1.0.11-1 GUI based ALSA utilities for specific hardwa
ii alsa-utils 1.0.11-6 ALSA utilities
rc alsamixergui 0.9.0rc2-1-9 graphical soundcard mixer for ALSA soundcard
rc alsaplayer-gtk 0.99.76-8 PCM player designed for ALSA (GTK version)
rc alsaplayer-xosd 0.99.76-8 PCM player designed for ALSA (osd version)
ii gnome-alsamixer 0.9.6-3 ALSA sound mixer for GNOME
ii gstreamer0.10-alsa 0.10.9-2 GStreamer plugin for ALSA
ii gstreamer0.8-alsa 0.8.12-4 ALSA plugin for GStreamer
ii libpt-plugins-alsa 1.10.1.dfsg-1 Portable Windows Library Audio Plugin for th


uname -a
Linux dacerpc64 2.6.17-2-amd64 #1 SMP Wed Sep 13 17:49:33 CEST 2006 x86_64 GNU/Linux


with:
sudo speaker-test -c 6

speaker-test 1.0.11

Playback device is default
Stream parameters are 48000Hz, S16_LE, 6 channels
Using 16 octaves of pink noise
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 2048 to 16384
Period size range from 1024 to 1024
Using max buffer size 16384
Periods = 4
was set period_size = 1024
was set buffer_size = 16384
0 - Front Left
4 - Center
1 - Front Right
3 - Rear Right
2 - Rear Left
5 - LFE


I hear 0 and 1 fine, but no others.

Thanks for replies
dclemen is offline   Reply With Quote