View Single Post
Old 09-24-06, 05:55 AM   #3
newgen23
Registered User
 
Join Date: Sep 2006
Posts: 12
Default Re: nvidia_drv.so - cannot open shared object file: No such file or directory

The driver gets installed in /usr/lib/xorg/modules/drivers. I have also tried to specify the install directory with --x-prefix of --x-module-path. No difference.

When moving/deleting the file nvidia_drv.so, startx says:
Backtrace:
0: /usr/bin/X11/X(xf86SigHandler+0x89) [0x80b67d9]
1: [0xffffe500]
2: /usr/bin/X11/X(LoaderOpen+0x193) [0x80a2353]
3: /usr/bin/X11/X(LoadModule+0x4db) [0x80a423b]
4: /usr/bin/X11/X(xf86LoadModules+0x98) [0x809ee08]
5: /usr/bin/X11/X(InitOutput+0x4c1) [0x809fe51]
6: /usr/bin/X11/X(main+0x276) [0x806e3c6]
7: /lib/tls/libc.so.6(__libc_start_main+0xc8) [0xf7d50ea8]
8: /usr/bin/X11/X(FontFileCompleteXLFD+0xad) [0x806d911]

Fatal server error:
Caught signal 11. Server aborting

When also deleting nvidia_drv.o, startx replies:
(EE) Failed to load module "nvidia" (module does not exist, 0)
(EE) No drivers available.

strace X says the driver is in place but cannot be opened? :
stat64("/usr/lib/xorg/modules/drivers/nvidia_drv.so", {st_mode=S_IFREG|0755, st_size=1172710, ...}) = 0
write(0, "(II) Loading /usr/lib/xorg/modul"..., 57) = 57
open("/usr/lib/xorg/modules/drivers/nvidia_drv.so", O_RDONLY) = 9
read(9, "\177ELF\2\1\1\0\0\0\0\0\0\0\0\0\3\0>\0\1\0\0\0`j\ 1\0\0"..., 256) = 256
lseek(9, 0, SEEK_SET) = 0
open("/usr/lib/xorg/modules/drivers/nvidia_drv.so", O_RDONLY) = 10
read(10, "\177ELF\2\1\1\0\0\0\0\0\0\0\0\0\3\0>\0\1\0\0\0`j\ 1\0\0"..., 512) = 512
close(10) = 0
write(2, "dlopen: /usr/lib/xorg/modules/dr"..., 111dlopen: /usr/lib/xorg/modules/drivers/nvidia_drv.so: cannot open shared object file: No such file or directory

Last edited by newgen23; 09-24-06 at 06:22 AM.
newgen23 is offline   Reply With Quote