Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 10-02-06, 03:38 AM   #1
Clontarf_X
Registered User
 
Join Date: Aug 2004
Posts: 8
Default NVIDIA Drivers - Version Mismatch on X Launch

X Window System Version 7.0.0
kubuntu dapper drake 2.6.15-23-amd64-generic

Installed NVIDIA-Linux-x86_64-1.0-9625-pkg2.run OK
Started kdm OK

Rebooted the machine
- KDM Fails (well, X really)

Says something about a version mismatch, saying the kernel (or X) contains 7174 and I am trying to use 9625. Sorry I can't be more specific but usually I don't run into problems and therefore have not learned how to log the output of the screen to a file :P

The nvidia module loads fine, it just seems X is confused as to what it is meant to be using

If anyone has any ideas please post! Otherwise give me some instructions to follow and I shall do so.

It might also be of note that during the NVIDIA installation it mentioned it did not know where to put the library? files? I can attach that also if needed

#edit* I know it isn't the nvidia drivers fault, just looking for answers! :P

Cheers!

- Shane
Attached Files
File Type: log Xorg.log (17.1 KB, 101 views)
File Type: log nvidia-installer.log (40.2 KB, 96 views)

Last edited by Clontarf_X; 10-02-06 at 05:31 AM. Reason: subject for easier search results
Clontarf_X is offline   Reply With Quote
Old 10-02-06, 04:07 AM   #2
energyman76b
Registered User
 
Join Date: Dec 2002
Location: Clausthal/Germany
Posts: 1,104
Default Re: 9625 & Xorg 7

you need to deinstall all ubuntu installed drivers.

I don't know the exact package name, but the problem has came up several times. Forum search will help you.
energyman76b is offline   Reply With Quote
Old 10-02-06, 04:09 AM   #3
Clontarf_X
Registered User
 
Join Date: Aug 2004
Posts: 8
Default Re: NVIDIA Drivers - Version Mismatch on X Launch

Forum search hasn't turned up anything as yet but I will keep looking

Thanks for popping in!

Last edited by Clontarf_X; 10-02-06 at 05:32 AM.
Clontarf_X is offline   Reply With Quote
Old 10-02-06, 05:22 AM   #4
Clontarf_X
Registered User
 
Join Date: Aug 2004
Posts: 8
Default Re: NVIDIA Drivers - Version Mismatch on X Launch

OK after some searching I find mention of linux-restricted-modules
- http://www.nvnews.net/vbulletin/showthread.php?t=70787

*edit* seems they are in fact installed, as opposed to my previous statement of "they aren't". Will try this when I get home...

Obviously this is a version mismatch error. Anyone have any tips on how to resolve said error?

Last edited by Clontarf_X; 10-02-06 at 05:32 AM.
Clontarf_X is offline   Reply With Quote
Old 10-02-06, 06:11 AM   #5
energyman76b
Registered User
 
Join Date: Dec 2002
Location: Clausthal/Germany
Posts: 1,104
Default Re: 9625 & Xorg 7

again, you have probably installed a ubuntu driver package. deinstall it.

Or/and go to /lib/modules/kernel-version/video and remove nvidia.ko
energyman76b is offline   Reply With Quote
Old 10-02-06, 08:44 AM   #6
czarnyckm
Registered User
 
Join Date: Aug 2005
Posts: 16
Default Re: 9625 & Xorg 7

You must change /etc/init.d/nvidia-glx execute attribute to false if you want to use nvidia install package
chmod uga-x /etc/init.d/nvidia-glx
czarnyckm is offline   Reply With Quote
Old 10-02-06, 10:51 AM   #7
Clontarf_X
Registered User
 
Join Date: Aug 2004
Posts: 8
Default Re: 9625 & Xorg 7

OK, did exactly that and removed linux-restricted-modules, restarted the machine and booted right into 9625 without a problem.

Thanks heaps energyman76b and czarnyckm. I need to refine on my forum search skills. Sorry for wasting your time! :P

Quote:
*edit* seems they are in fact installed, as opposed to my previous statement of "they aren't". Will try this when I get home...

Obviously this is a version mismatch error. Anyone have any tips on how to resolve said error?
I hope you didn't take offence to the above energyman76b as none was intended, much wuv for you
Clontarf_X is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with 173.14.35 and xorg 1.12 joedoe NVIDIA Linux 4 07-09-12 02:11 PM
173.14.34 -- Xorg 1.12.1 & 1.11.4, glx module fails to load mereset NVIDIA Linux 17 06-10-12 01:24 AM
Xorg crash and system freeze l_r_mcglashan NVIDIA Linux 0 05-17-12 04:01 AM
Driver versions above 275.43 causing Xorg hangs with Quadro 130m ApeironTsuka NVIDIA Linux 2 05-13-12 03:42 PM
295.40 Drivers and Xorg 1:7.6+12 HIGH cpu usage norrland NVIDIA Linux 2 05-13-12 09:11 AM

All times are GMT -5. The time now is 05:43 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.