Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 10-02-06, 04:20 PM   #1
elehvi
Registered User
 
Join Date: Nov 2005
Posts: 10
Unhappy XVideo performance with Compiz & sync_to_vblank

I'm having some xvideo performance issues while using Compiz (latest git) with sync_to_vblank enabled in Compiz gconf-key. Framerate seems too low, which makes picture somewhat choppy. Without sync_to_blank framerate is correct, but I get a lot of tearing in videos and Compiz in general.

This happens with every movie player, including MPlayer, Xine and Totem. I've disabled all Sync To VBlank options in NVIDIA X Server Settings, tried different Compiz refresh_rate settings but nothing seems to help.

Anyone having similar problems with the beta drivers? Or better yet - a solution?

Oh and I'm using Ubuntu Edgy on a notebook with a GeForce Go 7300.
elehvi is offline   Reply With Quote
Old 10-02-06, 04:24 PM   #2
elehvi
Registered User
 
Join Date: Nov 2005
Posts: 10
Default Re: XVideo performance with Compiz & sync_to_vblank

Here's the bug report.
Attached Files
File Type: bz2 nvidia-bug-report.log.bz2 (28.4 KB, 128 views)
elehvi is offline   Reply With Quote
Old 10-02-06, 04:28 PM   #3
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: XVideo performance with Compiz & sync_to_vblank

See
http://www.nvnews.net/vbulletin/showthread.php?t=77309
netllama is offline   Reply With Quote
Old 10-02-06, 04:52 PM   #4
elehvi
Registered User
 
Join Date: Nov 2005
Posts: 10
Default Re: XVideo performance with Compiz & sync_to_vblank

Thanks netllama, somehow I managed to miss that thread. So it's a Compiz problem then, namely Compiz doesn't correctly sync xvideo to vblank.

Oh well, I hope the Compiz developers are aware of this.
elehvi is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Boost Your Performance Goals 10x ' This Week on inside* Publications News Archived News Items 0 05-13-12 05:20 PM
NVIDIA Unleashes the GeForce GTX 670 Graphics Card ' Performance Perfected (WCCFTECH) News GeForce GTX 670 Reviews 0 05-10-12 08:40 AM
My UT2003 Tweak Guide DXnfiniteFX Gaming Central 48 10-30-02 11:59 PM
xvideo crash elanthis NVIDIA Linux 5 10-29-02 07:12 PM
so let's try this again in the new forum - bad performance with correctly inst.driver neutrino NVIDIA Linux 11 08-01-02 04:19 PM

All times are GMT -5. The time now is 02:07 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.