Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-13-03, 10:49 PM   #1
enygma
Registered User
 
Join Date: Apr 2003
Posts: 3
Default Big problem with new drivers in Redhat 7.3

Well, I have installed Redhat 7.3 on my system. I have been using Redhat 7.3 for a while now. Basically, what happened, right after I installed Redhat 7.3, one of the first things I did was download the latest NVidia drivers. I thought, "Sweet, new drivers in an easy to install file!". So, I download the drivers, install them, and modify my XF86Config-4 file accordingly. I go to restart the X server and the system hangs.

X doesn't load up anymore. I am stuck at a screen full of ASCII characters and I just can't do anthing. My keyboard and mouse are pretty much locked. CTRL+ALT+F2 or anything like that will not work, and it automatically boots into X. I don't know how to avoid booting into X. My linux installation for me is literally rendered useless.

Is there any way that I can boot linux without loading X? Or is there a way I can edit my XF86Config-4 file outside of Linux?

EDIT: I found what the problem was in their errata, but I still wouldn't mind finding out how to get things back to normal.

o Starting X with AGP 8x video cards on systems with KT400 AGP
chipsets cause system hangs.

Solution: this problem can be worked around by disabling AGP
(Option "NvAGP" "0") in your XF86Config file.

Alternatively, you may be able to enable AGP 8x on your KT400 based
system by overriding the default NVreg_EnableAGPSBA registry key.
To do this you can either:

- set the value on the modprobe command line; for example:
modprobe nvidia NVreg_EnableAGPSBA=1

- add an options line to your module configuration file,
usually /etc/modules.conf; for example:
options nvidia NVreg_EnableAGPSBA=1

and use NVIDIA's AGP (Option "NvAGP" "1" in the Screen section
of your XF86Config file).

Last edited by enygma; 04-13-03 at 10:55 PM.
enygma is offline   Reply With Quote
Old 04-14-03, 12:22 PM   #2
kisetsu
Registered User
 
Join Date: Apr 2003
Posts: 1
Default

Use a linux boot disk to boot to single user mode. From there, edit your /etci/inittab file to start from run level 3, which is multiuser mode, instead of run level 5, which is X11. I'm on RH 9, but I'm pretty sure the syntax hasn't changed, so look for the line that says:
Code:
id:5:initdefault
and change the 5 to 3.

Reboot sans boot disk, and you should have a nice command line login.
__________________
~~~kisetsu...
kisetsu is offline   Reply With Quote
Old 04-14-03, 12:46 PM   #3
enygma
Registered User
 
Join Date: Apr 2003
Posts: 3
Default

Thanks for the info. I did however find another way. My PC doesn't have a floppy drive so boot disk is out of the question. I use GRUB as my bootloader. I just press 'a' in the bootloader to edit the boot arguments. then I just add a 3 to the end and hit enter. It was very easy...

In LILO, I believe you type LINUX 3.

It is back up and running. I uninstalled the drivers and installed older ones and things run great.

Last edited by enygma; 04-14-03 at 12:51 PM.
enygma is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
nForce + RedHat 7.3 Success Story rtz NVIDIA Linux 47 02-15-03 02:20 AM
Radeon 9700 not all that? sancheuz Other Desktop Graphics Cards 200 10-12-02 09:31 PM
Strange RedHat 7.3 issues with A7N266-C nforceuser NVIDIA Linux 8 09-27-02 03:16 PM
Redhat 7.3 + Nvidia drivers 3123 = troubles e-r-a-n NVIDIA Linux 4 09-17-02 12:26 PM
2960 drivers, redhat 7.3, kernel normanpang NVIDIA Linux 6 08-03-02 12:11 AM

All times are GMT -5. The time now is 03:20 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.