Go Back   nV News Forums > Linux Support Forums > NVIDIA FreeBSD

Newegg Daily Deals

Reply
 
Thread Tools
Old 09-24-06, 11:52 AM   #1
Almindor
Registered User
 
Join Date: Sep 2006
Posts: 3
Default Microfreezes with 6600 GT

I have GeForce 6600 GT AGP (asus) on freeBSD 6.2-BETA1 (yeah I know..)

I get microfreezes on any 3d application I try. It reminds of some buffer problem. The FPS are ok "between" but every ~1 second it simply "feezes" for about 1/3 of a second or so.

I tried using both agp drivers and also tried lagacy driver (which shouldn't work on 6.x but does hehe) but the results are always same.

Anyone knows what this might be?
Almindor is offline   Reply With Quote
Old 09-26-06, 03:01 PM   #2
Almindor
Registered User
 
Join Date: Sep 2006
Posts: 3
Default Re: Microfreezes with 6600 GT

Just some additional info to my problem.

I also pasted this problem on bsdforums, and a discussion followd which made me post lots of info there. So if you need various logs or kernel sysctl here it is along with some "theoretizing"

http://www.bsdforums.org/forums/showthread.php?t=44394
Almindor is offline   Reply With Quote
Old 09-29-06, 04:17 AM   #3
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: Microfreezes with 6600 GT

Does this problem reproduce if you disable AGP support?
zander is offline   Reply With Quote
Old 10-23-06, 04:47 AM   #4
Almindor
Registered User
 
Join Date: Sep 2006
Posts: 3
Default Re: Microfreezes with 6600 GT

Hello again.

Sorry I forgot about this forum for a time, the problem was "kind of fixed" in the meantime.

It seems that certain gnome applets which test for net activity caused this. Each time they polled the OS it made these microfreezes (but eg: top didn't report much activity).

It's possibly a kernel weakness or driver problem or just very short spikes in CPU usage. I ktraced one of the applets and it did loads of syscalls in a loop each time which would cause some ugly context switches.

In any case, removing the problematic applets (gkrellm btw works ok so it's a design issue with the applets I guess) helped.
Almindor is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:24 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.