Go Back   nV News Forums > Linux Support Forums > General Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 10-22-06, 03:20 PM   #1
denial-music.de
Registered User
 
Join Date: Aug 2006
Posts: 4
Default nforce install problems on 2.6.17-*

Hi i try to install the nvidia drivers by this howto at ubuntu edgy amd 64:
http://wiki.ubuntuusers.de/Nvidia_NForce
so in englisch :
----------------------------
1.first get by apt :

build-essential
linux-headers-386 [4]
libqt3-mt
---------------------------

2.extract the drivers
sh NFORCE-Linux-x86.... -x
---------------------------

3.change the code in NFORCE-Linux-x86-***pkg1/nvsound/main/nvmain.c
line 2191

from : MODULE_PARM(vapu_enable, "i");
to : MODULE_PARM(vapu_enable, int, 0444);

and in
NFORCE-Linux-x86-***pkg1/nvsound/main/Makefile.kbuild

line 51 and 53-60
with a # before the code

----------------------------
4. run in NFORCE-Linux-x86***-pkg1/nvsound/main

make sudo
make install
sudo depmod -a
sudo modprobe nvsound


my problem is : when i do "make sudo" i get :
-----------------
make sudo
make[1]: *** No rule to make target `sudo'. Stop.
make: *** [sudo.o] Error 2
-----------------
when i do sudo make :

----------------------------------
/home/bart/Desktop/NFORCE-Linux-x86_64-1.0-0310-pkg1/nvsound/main/nvmain.c:2191: error: expected ‘)’ before ‘int’
make[3]: *** [/home/bart/Desktop/NFORCE-Linux-x86_64-1.0-0310-pkg1/nvsound/main/nvmain.o] Error 1
make[2]: *** [_module_/home/bart/Desktop/NFORCE-Linux-x86_64-1.0-0310-pkg1/nvsound/main] Error 2
---------------------------
please help !!!! ;o)
denial-music.de is offline   Reply With Quote
Old 10-26-06, 12:05 PM   #2
jocko
Registered User
 
Join Date: Aug 2006
Posts: 7
Default Re: nforce install problems on 2.6.17-*

Hi, I think the page you linked to is based on an early version of my howto on the ubuntu forums.
Unfortunately there seems to be a few mistakes in that page and a few very important steps are missing.

Just follow all the steps in my howto (you've already done "step 1" and "step 3"). Under "step 4" you should follow "part II" (copy / paste the changes in nvmain.c to avoid mistakes).





Hope you get it working. And if you are a registered user on wiki.ubuntuusers.de could you update the instructions?

Last edited by jocko; 10-26-06 at 12:30 PM.
jocko is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mageia 2 Cannot Install 71.86.15 for Riva TNT/TNT2 kbulgrien NVIDIA Linux 3 06-29-12 08:27 AM
nForce + RedHat 7.3 Success Story rtz NVIDIA Linux 47 02-15-03 02:20 AM
Red Hat null(limbo beta 3), guide to install Nvidia Drivers utiel NVIDIA Linux 21 09-30-02 05:32 PM
Leadtek Nforce problems druga runda CPUs, Motherboards And Memory 4 09-18-02 08:26 AM
Newby question about nforce.... superconti NVIDIA Linux 2 09-07-02 11:46 PM

All times are GMT -5. The time now is 02:12 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2014, nV News.