Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-18-03, 09:38 PM   #1
RickW
Registered User
 
Join Date: Apr 2003
Location: Las Vegas
Posts: 3
Default NVidia 4349 driver on Dell 8200 Laptop

Hi, I am having a strange problem. I installed the lastest driver on Mandrake 9.1 on my Dell 8200 Laptop. At first I could not get X to start. I found that I had to put the line "insmod nvidia" as the first line after start in /etc/rc.d/init.d/dm.
Everything works fine but I would like to get this figured out and fixed.
Following is info on my system
GeForce4 440 Go
BIOS = 04.17.00.55.41
Driver 1.0-4349
Dell 8200 Laptop
Pentium 4 2.0GHZ
Mandrake 9.1

In /var/log/syslog, this line appears
Warning: loading /lib/modules/2.4.21-0.13mdk/kernel/drivers/video/nvidia.o will taint the kernel: non-GPL license - NVIDIA

I think I have attched a file that has XFConfig-4, XFree86.0 and nvidia loader.log
RickW is offline   Reply With Quote
Old 04-18-03, 09:54 PM   #2
Andy Mecham
l33t master
 
Join Date: Jul 2002
Location: Santa Clara, CA
Posts: 1,163
Default

Do you have
Code:
alias char-major-195 nvidia
in your /etc/modules.conf file?

--andy
__________________
Andy Mecham
NVIDIA Corporation
Andy Mecham is offline   Reply With Quote
Old 04-18-03, 09:55 PM   #3
Andy Mecham
l33t master
 
Join Date: Jul 2002
Location: Santa Clara, CA
Posts: 1,163
Default

... or
Code:
alias /dev/nvidia* nvidia
if you're using devfs.

--andy
__________________
Andy Mecham
NVIDIA Corporation
Andy Mecham is offline   Reply With Quote
Old 04-18-03, 09:59 PM   #4
RickW
Registered User
 
Join Date: Apr 2003
Location: Las Vegas
Posts: 3
Default

I have alias char-major-195 nvidia
RickW is offline   Reply With Quote
Old 04-18-03, 10:12 PM   #5
RickW
Registered User
 
Join Date: Apr 2003
Location: Las Vegas
Posts: 3
Default

Andy, I changed the line in modules.conf to alias /dev/nvidia* nvidia, commented out the line in /etc/rc.d/init.d/dm and it worked.

Thanks a lot!!!!!

By the way, I really like the new loader. Great work.
RickW is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
nvidia driver quality decrease? legluondunet NVIDIA Linux 17 06-26-12 11:03 AM
Need Help Installing NVIDIA Tesla M2070Q in Linux RHEL5 Ferianto85 NVIDIA Linux 0 05-18-12 09:35 PM
Getting the proprietary nvidia driver to run with Debian 3.0 r0 (woody) Katchina404 NVIDIA Linux 9 01-12-03 09:49 AM
nvidia + 2.4.19 gentoo = messed up ulukay NVIDIA Linux 18 11-02-02 12:58 AM

All times are GMT -5. The time now is 01:18 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.