Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 08-15-06, 04:13 PM   #1
heli
Registered User
 
Join Date: Aug 2006
Posts: 10
Default Installation problems with FC5

Hi,

I am trying to install NVIDIA-Linux-x86-1.0-8762-pkg1.run on my FC5 which fails with the error,

Unable to find the kernel source tree for the currently running
kernel. Please make sure you have installed the kernel source files
for your kernel and that they are properly configured; on Red Hat
Linux systems, for example, be sure you have the 'kernel-source' RPM
installed. If you know the correct kernel source files are
installed, you may specify the kernel source path with the
'--kernel-source-path' command line option.

I have attached the log file with this email. I am trying to install the driver on
Linux 2.6.17-1.2157_FC5smp

Let me know what am I missing or do I need to run any patches.

Thanks
Heli
Attached Files
File Type: log nvidia-installer.log (2.3 KB, 83 views)
heli is offline   Reply With Quote
Old 08-15-06, 04:14 PM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Installation problems with FC5

See: http://www.nvnews.net/vbulletin/showthread.php?t=72490
netllama is offline   Reply With Quote
Old 08-15-06, 04:19 PM   #3
heli
Registered User
 
Join Date: Aug 2006
Posts: 10
Default Re: Installation problems with FC5

Yes I tried that. I did the yum install of the xorg-sdk and kernel-devel by running the following commands,

yum install kernel-smp-devel xorg-x11-server-sdk pkgconfig
and yum update and then reboot the system and run the installer again. It still gives me the same message. Please advice.

Any help is appreciated.

Thanks
Heli
heli is offline   Reply With Quote
Old 08-15-06, 05:06 PM   #4
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Installation problems with FC5

The installer log that you attached indicates that you don't have the correct kernel-devel RPM installed. I'd like to see an updated installer log along with the output from:
uname -a
rpm -qa | grep kernel

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 08-15-06, 05:24 PM   #5
heli
Registered User
 
Join Date: Aug 2006
Posts: 10
Default Re: Installation problems with FC5

Hi,

Here is the output

# uname -a
Linux test-stradis 2.6.17-1.2157_FC5smp #1 SMP Tue Jul 11 23:24:16 EDT 2006 i686 i686 i386 GNU/Linux

# rpm -qa | grep kernel
kernel-smp-2.6.17-1.2174_FC5
kernel-2.6.17-1.2174_FC5
kernel-devel-2.6.17-1.2174_FC5
kernel-2.6.17-1.2157_FC5
kernel-smp-2.6.17-1.2157_FC5
kernel-smp-devel-2.6.17-1.2174_FC5

I see what you are saying. I should have kernel-smp-devel-2.6.17-1.2157_FC5 installed. The installer log is attached with this post again. I thought the command

yum install kernel-devel xorg-x11-server-sdk pkgconfig would install the correct devel version. Let me know if you have an idea on how to make sure the correct devel will be installed. I will try and search it too.

Thanks
Heli
Attached Files
File Type: log nvidia-installer.log (2.3 KB, 101 views)
heli is offline   Reply With Quote
Old 08-15-06, 05:43 PM   #6
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Installation problems with FC5

You need to run "yum update kernel-smp-devel".
netllama is offline   Reply With Quote
Old 08-15-06, 06:27 PM   #7
heli
Registered User
 
Join Date: Aug 2006
Posts: 10
Default Re: Installation problems with FC5

Hi,

Thanks so much for your help but when i run

yum updat kernel-smp-devel

it gives me,

Could not find update match for kernel-smp-devel
No Packages marked for Update/Obsoletion


and the package smp-devel still remains the same. Please help.

Thanks
Heli
heli is offline   Reply With Quote
Old 08-15-06, 06:47 PM   #8
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Installation problems with FC5

I'm not sure what is wrong with your environment at this point, however its not an nvidia driver issue. You can either manually download & install the missing RPM, or perhaps ask for help in getting it installed via yum from a FC support group/forum.

Thanks,
Lonni
netllama is offline   Reply With Quote

Old 08-15-06, 07:16 PM   #9
heli
Registered User
 
Join Date: Aug 2006
Posts: 10
Default Re: Installation problems with FC5

Hey,

Thanks for pointing me in the right direction. I downloaded the correct devel rpm and installed and now it works great.

Thank you so much
Heli
heli is offline   Reply With Quote
Old 11-09-06, 08:17 PM   #10
heli
Registered User
 
Join Date: Aug 2006
Posts: 10
Default Re: Installation problems with FC5

Okay I am having a new problem now,

here is output of uname -a

Linux Split2 2.6.18-1.2200.fc5 #1 Sat Oct 14 16:59:26 EDT 2006 i686 i686 i386 GNU/Linux

and here is output of rpm -qa | grep "kernel"
kernel-devel-2.6.18-1.2200.fc5
kernel-2.6.15-1.2054_FC5
kernel-2.6.18-1.2200.fc5

and I have attached the installer - log file with this - the insallation fails with the kernel-source not found error,

Please advise what needs to be done - I am lost on this one.
Attached Files
File Type: log nvidia-installer.log (2.8 KB, 91 views)
heli is offline   Reply With Quote
Old 11-09-06, 10:32 PM   #11
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Installation problems with FC5

ERROR: Unable to determine the version of the kernel sources located in

'/lib/modules/2.6.18-1.2200.fc5/source'. Please make sure you have

installed the kernel source files for your kernel and that they are

properly configured; on Red Hat Linux systems, for example, be sure you

have the 'kernel-source' RPM installed. If you know the correct kernel

source files are installed, you may specify the kernel source path with

the '--kernel-source-path' command line option.

Seems that something has broken your kernel headers. You could try reinstalling the kernel-devel RPM, but beyond that, this isn't a driver bug, its something specific to your environment.

Thanks,
Lonni
netllama is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
problems with drivers after 295.40 (OpenSuSE 12.1, GeFroce 7900 GS, Phenom II X4) alawa NVIDIA Linux 0 06-09-12 07:37 PM
Nvidia Problems in Slackware 8.1 xtreme NVIDIA Linux 3 10-01-02 01:03 PM
Another? installation problem on RH7.3 oddjob NVIDIA Linux 4 09-22-02 09:13 PM
Intel AA & Win XPProSP1 slipstream installation? cenkog Microsoft Windows XP And Vista 1 09-17-02 05:55 PM
DirectX 8 problems with GeForce4 Derwin NVIDIA GeForce 7, 8, And 9 Series 19 08-20-02 02:23 AM

All times are GMT -5. The time now is 06:41 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.