Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-10-06, 03:48 AM   #1
livingpixels
Registered User
 
Join Date: Nov 2006
Posts: 2
Default blue window with XvMC on Quadro4 980 XGL

I've been trying to use XvMC to help playback HD content on my Quadro4 980 XGL but without any success. With mplayer and xine, I get a blue window (plus audio). With Myth I get a black screen. I've attached my nvidia-bug-report-log.txt and put the mplayer, xine and myth logs below.

Has anyone successfully used XvMC on a Quadro4 980? If I can't this working, I'm thinking of buying a GF 6600 just to get something more common since HD playback is stuttering quite a bit at 1080.

thanks,
bruce
-----
Here's the log for:
mplayer -vo xvmc -vc ffmpeg12mc House\ of\ Flying\ Daggers_1080.mpg
Code:
MPlayer 1.0rc1-4.0.3 (C) 2000-2006 MPlayer Team
CPU: Intel(R) Xeon(TM) CPU 2.80GHz (Family: 15, Model: 2, Stepping: 9)
CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2

Playing House of Flying Daggers_1080.mpg.
TS file format detected.
VIDEO MPEG2(pid=2112) AUDIO A52(pid=2113) NO SUBS (yet)!  PROGRAM N. 1
VIDEO:  MPEG2  1920x1080  (aspect 3)  29.970 fps  38810.4 kbps (4851.3 kbyte/s)
vo_xvmc: X-Video extension 2.2
vo_xvmc: X-Video MotionCompensation Extension version 1.1
==========================================================================
Forced video codec: ffmpeg12mc
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
[VD_FFMPEG] XVMC accelerated codec.
Selected video codec: [ffmpeg12mc] vfm: ffmpeg (FFmpeg MPEG-1/2 (XvMC))
==========================================================================
==========================================================================
Opening audio decoder: [liba52] AC3 decoding with liba52
Using SSE optimized IMDCT transform
Using MMX optimized resampler
AUDIO: 48000 Hz, 2 ch, s16le, 384.0 kbit/25.00% (ratio: 48000->192000)
Selected audio codec: [a52] afm: liba52 (AC3-liba52)
==========================================================================
AO: [oss] 48000Hz 2ch s16le (2 bytes per sample)
Starting playback...
[VD_FFMPEG] XVMC-accelerated MPEG-2.
[VD_FFMPEG] Trying pixfmt=0.
VDec: vo config request - 1920 x 1080 (preferred colorspace: MPEG1/2 Motion Compensation and IDCT)
VDec: using MPEG1/2 Motion Compensation as output csp (no 1)
Movie-Aspect is 1.78:1 - prescaling to correct movie aspect.
VO: [xvmc] 1920x1080 => 1920x1080 MPEG1/2 Motion Compensation
vo_xvmc: Port 183 grabed
vo_xvmc: Found matching surface with id=4F434F4D on 183 port at 1 adapter
vo_xvmc: Allocated Direct Context
vo_xvmc: data_blocks allocated
vo_xvmc: mv_blocks allocated
vo_xvmc: Motion Compensation context allocated - 8 surfaces
vo_xvmc: idct=0 unsigned_intra=1
vo_xvmc: looking for OSD support
    Subpicture id 0x34344149
vo_xvmc: OSD support by additional frontend rendering
aspect: Warning: no suitable new res found!
aspect: Warning: no suitable new res found!
aspect: Warning: no suitable new res found!
aspect: Warning: no suitable new res found!
aspect: Warning: no suitable new res found! 1/  1 ??% ??% ??,?% 0 0
New_Face failed. Maybe the font path is wrong. 2 ??% ??% ??,?% 1 0
Please supply the text font file (~/.mplayer/subfont.ttf).
subtitle font: load_sub_face failed.
A:1632.1 V:1632.3 A-V: -0.107 ct: -0.040  16/ 13 322% 31%  3.7% 11 0
demux_mpg: 24000/1001fps progressive NTSC content detected, switching framerate.
A:1634.5 V:1634.0 A-V:  0.552 ct: -0.210  57/ 54 167% 15%  2.6% 50 0
Snippets from:
xine --bug-report -V xxmc House\ of\ Flying\ Daggers_1080.mpg

Code:
This is xine (X11 gui) - a free video player v0.99.4.
...
   Number of extensions:   29
...
     XVideo-MotionCompensation:    [opcode: 141, base (error: 153)]
...
load_plugins: plugin /usr/lib/xine/plugins/1.1.1/xineplug_vo_out_xxmc.so found
...
init class succeeded
video_out_xxmc: using Xv port 183 from adaptor NV17 Video Overlay for hardware colorspace conversion and scaling.
video_out_xxmc: double buffering mode = 1
video_out_xxmc: port attribute XV_COLORKEY (6) value is 66046
video_out_xxmc: port attribute XV_AUTOPAINT_COLORKEY (7) value is 0
video_out_xxmc: port attribute XV_BRIGHTNESS (5) value is 0
video_out_xxmc: port attribute XV_CONTRAST (4) value is 4096
video_out_xxmc: port attribute XV_SATURATION (3) value is 4096
video_out_xxmc: ignoring broken XV_HUE settings on NVidia cards
video_out_xxmc: XvMC extension present.
video_out_xxmc: Found 1 XvMC surface types
video_out_xxmc: Surface type 0: Max size: 2032 2032.
video_out_xxmc: Surface type 0: Max subpic size: 2046 2046.
video_out_xxmc: Surface type 0: Found 2 XvMC subpicture types
video_out_xxmc: Surface type 0: Detected and using IA44 subpicture type.
video_out_xxmc: this adaptor supports the yuy2 format.
video_out_xxmc: this adaptor supports the yv12 format.
video_out_xxmc: Unichrome CPU saving is off.
x11osd: unscaled overlay created (Colorkey mode).
...
video_out_xxmc: VO_PROP_ASPECT_RATIO(0)
...
libmpeg2: output port has XxMC capability
load_plugins: plugin mpeg2 will be used for video streamtype 00.
video_out_xxmc: New format. Need to change XvMC Context.
width: 1920 height: 1088 mpeg: 2 acceleration: 7
video_out_xxmc: Surface type 0. Capabilities 0x       2 0x       1
video_out_xxmc:   Requests: 0x       2 0x       4
video_out_xxmc: Surface type 0. Capabilities 0x       2 0x       1
video_out_xxmc:   Requests: 0x       2 0x       2
video_out_xxmc: Surface type 0. Capabilities 0x       2 0x       1
video_out_xxmc:   Requests: 0x       2 0x       1
video_out_xxmc: Creating new XvMC Context 1329811277
0 0;0 0;0 0;0 0;
video_out_xxmc: Created subpicture 0
video_out_xxmc: Disposing of subpicture 0
0 1;0 0;0 0;0 0;
video_out_xxmc: Using hardware decoding for this stream.
0 0;0 0;0 0;0 0;0 0;0 0;0 0;0 0;0 0;0 0;0 0;0 0;0 0;0 0;0 0;0 0;
video_out_xxmc: Created surface 0
load_plugins: plugin a/52 will be used for audio streamtype 00.
audio_alsa_out:open pause_resume=0
output sample rate 48000
audio jump, diff=63410
1 1;0 0;0 0;0 0;0 0;0 0;0 0;0 0;0 0;0 0;0 0;0 0;0 0;0 0;0 0;0 0;
video_out_xxmc: Created surface 1
Here's the log from mythfrontend:
Code:
2006-11-10 00:49:02.159 Using runtime prefix = /usr/local
2006-11-10 00:49:02.174 DPMS is active.
2006-11-10 00:49:02.413 New DB connection, total: 1
2006-11-10 00:49:02.505 Connected to database 'mythconverg' at host: localhost
2006-11-10 00:49:02.509 Total desktop dim: 3200x1200, with 2 screen[s].
2006-11-10 00:49:02.514 Using screen 1, 1920x1200 at 0,0
2006-11-10 00:49:02.603 Current Schema Version: 1158
2006-11-10 00:49:02.603 mythfrontend version: 0.20.20060828-3 www.mythtv.org
2006-11-10 00:49:02.604 Enabled verbose msgs:  important general
Xlib:  extension "RANDR" missing on display ":0.0".
DisplaResX: Unable to XRRgetScreenInfo
Xlib:  extension "RANDR" missing on display ":0.0".
DisplaResX: Unable to XRRgetScreenInfo
2006-11-10 00:49:03.552 Total desktop dim: 3200x1200, with 2 screen[s].
2006-11-10 00:49:03.554 Using screen 1, 1920x1200 at 0,0
2006-11-10 00:49:03.555 Switching to square mode (G.A.N.T.)
2006-11-10 00:49:03.668 Using the Qt painter
2006-11-10 00:49:04.441 Joystick disabled.
2006-11-10 00:49:05.534 Loading from: /usr/local/share/mythtv/themes/G.A.N.T./base.xml
2006-11-10 00:49:06.102 Loading from: /usr/local/share/mythtv/themes/default/base.xml
2006-11-10 00:49:06.281 Registering Internal as a media playback plugin.
2006-11-10 00:49:06.422 Registering MythDVD DVD Media Handler as a media handler ext()
2006-11-10 00:49:06.426 Registering MythDVD VCD Media Handler as a media handler ext()
2006-11-10 00:49:06.533 Registering MythGallery Media Handler 1/2 as a media handler ext()
2006-11-10 00:49:06.533 Registering MythGallery Media Handler 2/2 as a media handler ext(gif,jpg,png)
Failed to run 'cdrecord --scanbus'
Failed to run 'cdrecord --scanbus'
adding: ATAPI:0,0,0 -- LTR-48246S
2006-11-10 00:49:10.225 Registering MythMusic Media Handler 1/2 as a media handler ext()
2006-11-10 00:49:10.226 Registering MythMusic Media Handler 2/2 as a media handler ext(ogg,mp3,aac,flac)2006-11-10 00:49:33.694 XMLParse::LoadTheme using /usr/local/share/mythtv/themes/G.A.N.T./ui.xml
2006-11-10 00:49:36.100 Connecting to backend server: 127.0.0.1:6543 (try 1 of 5)
2006-11-10 00:49:36.249 Using protocol version 30
0: start_time: 152.968 duration: 20.905
1: start_time: 152.902 duration: 20.906
stream: start_time: 1698.911 duration: 233.010 bitrate=10737 kb/s
2006-11-10 00:49:40.411 AFD: Opened codec 0x854afa0, id(MPEG2VIDEO) type(Video)
2006-11-10 00:49:40.434 AFD: Opened codec 0x854b560, id(AC3) type(Audio)
2006-11-10 00:49:42.203 New DB connection, total: 2
2006-11-10 00:49:42.205 New DB connection, total: 3
2006-11-10 00:49:42.526 Connected to database 'mythconverg' at host: localhost
2006-11-10 00:49:42.583 Connected to database 'mythconverg' at host: localhost
2006-11-10 00:49:43.030 TV: Attempting to change from None to WatchingPreRecorded
2006-11-10 00:49:43.085 DPMS Deactivated
0: start_time: 152.968 duration: 20.905
1: start_time: 152.902 duration: 20.906
stream: start_time: 1698.911 duration: 233.010 bitrate=10737 kb/s
2006-11-10 00:49:44.036 AFD Error: Could not find decoder for codec (MPEG2VIDEO_XVMC), ignoring.
2006-11-10 00:49:44.037 AFD: Opened codec 0x84e0770, id(AC3) type(Audio)
2006-11-10 00:49:44.189 Opening OSS audio device '/dev/dsp'.
2006-11-10 00:49:44.298 VideoOutputXv: XvMCTex: Init failed
2006-11-10 00:49:44.299 VideoOutputXv: XvMC Adaptor Name: 'NV17 Video Overlay'
2006-11-10 00:49:45.056 Using realtime priority.
2006-11-10 00:49:45.058 TV: Changing from None to WatchingPreRecorded
2006-11-10 00:49:45.246 Video timing method: USleep with busy wait
nvidia drivers: 8762
Attached Files
File Type: log nvidia-bug-report.log (124.9 KB, 92 views)
livingpixels is offline   Reply With Quote
Old 11-10-06, 01:35 PM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: blue window with XvMC on Quadro4 980 XGL

Does this problem reproduce with the 1.0-9629 driver?
netllama is offline   Reply With Quote
Old 11-11-06, 03:01 AM   #3
livingpixels
Registered User
 
Join Date: Nov 2006
Posts: 2
Default Re: blue window with XvMC on Quadro4 980 XGL

I just installed 9629, restarted X which looks fine and rebuilt mplayer and myth. Unfortunately, mplayer gave the same results and an identical log. myth crashed early in initialization with a segfault :-(

I'm doing a clean rebuild of myth right now hoping that's the problem. Any suggestions are welcome.

thanks,
bruce
livingpixels is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
GL_EXT_texture_compression_s3tc support for Quadro4 700 XGL marvin24 NVIDIA Linux 3 08-20-03 09:00 AM

All times are GMT -5. The time now is 09:41 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.