Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-15-06, 11:12 AM   #13
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: URGENT! 7600CS (rev 02e1) stays black when screen via VGA extender

Just because this worked with older/different hardware doesn't mean that you're not running into a hardware limitation with the newer hardware. The signal tolerances for G7x based cards are far more restrictive (for performance & quality reasons) than in NV4x based cards.

If you can capture the EDID from your CRT, you could always instruct the driver to ignore the EDID (UseEDID set to false) and then just use a modeline based on the mode from the EDID that you wish to use. However, if your hardware is the problem, this also will not help.

What kind of CRT are you trying to use?
Have you confirmed that the problem is not present when connecting the CRT directly to the videocard without the VGA-extender and without a KVM?
netllama is offline   Reply With Quote
Old 11-15-06, 11:20 AM   #14
wahrheit2004
Registered User
 
Join Date: Mar 2006
Posts: 15
Default Re: URGENT! 7600CS (rev 02e1) stays black when screen via VGA extender

Hi netllama,

sure, if I use a CRT directly, than all is ok, because 7xxx can "talk" to screen.
I need a option that allows "do not talk to screen at all"!

We sometimes have different devices (f.e. NEC 4600 TFT, LG 3200 TFT, SAMSUNG P400 TFT etc.) and we must be sure, that admin settings (from modeline) are used whatever the display thinks.

Only this allows us rreproducable settings with different displays / KVMs / externders / boosters / etc.

AGAIN:
1.
Is there a "secret" command that allows "do not talk to monitor" so that VGA/DVI works, even if there is NO MONITOR connected (cable off)?

2.
6xxx was fine with it 7xxx not. Do we have to wait for 8xxx or move to Matrox/ATI ?
wahrheit2004 is offline   Reply With Quote
Old 11-15-06, 11:45 AM   #15
wahrheit2004
Registered User
 
Join Date: Mar 2006
Posts: 15
Default Re: URGENT! 7600CS (rev 02e1) stays black when screen via VGA extender

You said:

"If you can capture the EDID from your CRT, you could always instruct the driver to ignore the EDID (UseEDID set to false) and then just use a modeline based on the mode from the EDID that you wish to use. However, if your hardware is the problem, this also will not help."

does this means:
We can "read a edid.bin" that we allways want to and 7xxx with special modline will start X even if there is NO cable connected?

IF yes, this even will be fine to me.
HOW TO DO?
wahrheit2004 is offline   Reply With Quote
Old 11-15-06, 12:21 PM   #16
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: URGENT! 7600CS (rev 02e1) stays black when screen via VGA extender

You've already forced the driver into a state where it doesn't talk to the CRT. That is the root of the problem. What you need is to provide the driver with a modeline which the CRT can use. Alternatively, you can use the CustomEDID option, once you've captured the EDID. See the driver README for more details.

I should note that the above would be specific to one model of CRT. Also, from your information above, it sounds like you're using DFPs, not a CRT. That further complicates things as the acceptable modes on a DFP are significantly more restrictive than what a CRT would accept & work correctly with. Are you running these DFPs with a DVI-D cable or an analog cable?

However, none of the above may work if the problem here is a signal degredation problem due to the length of your VGA cable. It should work for the KVM, assuming that you're not using excessively long cables.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 11-15-06, 12:29 PM   #17
wahrheit2004
Registered User
 
Join Date: Mar 2006
Posts: 15
Default Re: URGENT! 7600CS (rev 02e1) stays black when screen via VGA extender

Hi Lonny,

I have the felling that we are not on the same page. Nevertheless lets come back to the road (not talking of KVM, DISPLAYS; DVI/VGA etc):

So you say with the Option:
"ConnectedMonitor" "CRT" with usual 1024x768@60 modeling (24bit)

this should work with 7xxx:
TESTCASE:
1. Boot your PC with 7xxx card inside, Runlevel 3
2. login root/pass
3. disconnect analoge VGA Cable (15pin)
4. startx
5. connect VGA Cable again -> display shall show video signal
correct?

EXACTLY THIS I NEED, like good old 6xxx doing this. Or need I more options activated that aboves TESTCASE works?
wahrheit2004 is offline   Reply With Quote
Old 11-15-06, 12:35 PM   #18
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: URGENT! 7600CS (rev 02e1) stays black when screen via VGA extender

The steps you've outlined are only expected to work if the mode that the driver is being instructed to use for your display is valid for your display *AND* there is no signal lost. You cannot ignore the influence that your KVM, DISPLAYS; DVI/VGA etc have on the problem you're reporting.

As I stated earlier, the problem you're reporting sounds very much like a hardware limitation, especially since its specific to G7x based cards.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 11-15-06, 12:42 PM   #19
wahrheit2004
Registered User
 
Join Date: Mar 2006
Posts: 15
Default Re: URGENT! 7600CS (rev 02e1) stays black when screen via VGA extender

Hi Lonni,

this is true. Since 7xxx we have this troubles.

TESTCASE #2
1. boot your linux station (nvidia driver installed, 7xxx)
--> you see X coming up
2. halt linux station
3. disconnect monitor VGA cable analoge 15pin
4. boot your station
5. wait 5min (all is booted)
6. connect VGA Cable

--> NOW I NEED A SIGNAL, but there is NONE!

a. with 6xxx this testcase works 100% ; I see X
b. with 7xxx NOT! ; no signal

--> What to set for driver / GFX_CARD BIOS etc to let 7xxx pass this Testcase too?


Thanks.
wahrheit2004 is offline   Reply With Quote
Old 11-15-06, 12:45 PM   #20
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: URGENT! 7600CS (rev 02e1) stays black when screen via VGA extender

Are you running these DFPs with a DVI-D cable or an analog cable?
netllama is offline   Reply With Quote

Old 11-15-06, 12:49 PM   #21
wahrheit2004
Registered User
 
Join Date: Mar 2006
Posts: 15
Default Re: URGENT! 7600CS (rev 02e1) stays black when screen via VGA extender

analog cable
wahrheit2004 is offline   Reply With Quote
Old 11-16-06, 12:59 PM   #22
wahrheit2004
Registered User
 
Join Date: Mar 2006
Posts: 15
Default Re: URGENT! 7600CS (rev 02e1) stays black when screen via VGA extender

Hey, now the thread stucks?
Any feedback?

Thanks!
wahrheit2004 is offline   Reply With Quote
Old 11-16-06, 01:10 PM   #23
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: URGENT! 7600CS (rev 02e1) stays black when screen via VGA extender

Have you followed everything that I suggested in post #16?
http://www.nvnews.net/vbulletin/show...6&postcount=16

If so, what are the results (along with a bug report)?
netllama is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 12:43 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.